summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-16 11:41:35 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-16 12:06:55 -0400
commit99c7510688e6954c7aadfadefbfc7ff3123d9150 (patch)
treee95341cce62f93e3df8d61013adac2b666cee0c5 /x11-base/xcb-proto/xcb-proto-1.15.1.ebuild
parentdev-libs/simdjson: add 2.0.4, drop 2.0.3 (diff)
downloadgentoo-99c7510688e6954c7aadfadefbfc7ff3123d9150.tar.gz
gentoo-99c7510688e6954c7aadfadefbfc7ff3123d9150.tar.bz2
gentoo-99c7510688e6954c7aadfadefbfc7ff3123d9150.zip
x11-base/xcb-proto: Version bump to 1.15.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base/xcb-proto/xcb-proto-1.15.1.ebuild')
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.15.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-base/xcb-proto/xcb-proto-1.15.1.ebuild b/x11-base/xcb-proto/xcb-proto-1.15.1.ebuild
new file mode 100644
index 000000000000..6340da91f79c
--- /dev/null
+++ b/x11-base/xcb-proto/xcb-proto-1.15.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+XORG_TARBALL_SUFFIX="xz"
+XORG_MODULE=proto/
+XORG_MULTILIB=yes
+
+inherit python-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2
+"
+
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+ # Don't use Python to find sitedir here.
+ PYTHON=true default
+}
+
+src_compile() {
+ :
+}
+
+xcbgen_install() {
+ # Use eclass to find sitedir instead.
+ emake -C xcbgen install DESTDIR="${D}" pythondir="$(python_get_sitedir)"
+ python_optimize
+}
+
+multilib_src_install() {
+ # Restrict SUBDIRS to prevent xcbgen with empty sitedir.
+ emake install DESTDIR="${D}" SUBDIRS=src
+ multilib_is_native_abi && python_foreach_impl xcbgen_install
+}