summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-16 11:41:35 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-16 12:06:55 -0400
commit99c7510688e6954c7aadfadefbfc7ff3123d9150 (patch)
treee95341cce62f93e3df8d61013adac2b666cee0c5 /x11-base/xcb-proto
parentdev-libs/simdjson: add 2.0.4, drop 2.0.3 (diff)
downloadgentoo-99c7510688e6954c7aadfadefbfc7ff3123d9150.tar.gz
gentoo-99c7510688e6954c7aadfadefbfc7ff3123d9150.tar.bz2
gentoo-99c7510688e6954c7aadfadefbfc7ff3123d9150.zip
x11-base/xcb-proto: Version bump to 1.15.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base/xcb-proto')
-rw-r--r--x11-base/xcb-proto/Manifest1
-rw-r--r--x11-base/xcb-proto/xcb-proto-1.15.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/x11-base/xcb-proto/Manifest b/x11-base/xcb-proto/Manifest
index 00dd8fdf1c5e..1d68310773de 100644
--- a/x11-base/xcb-proto/Manifest
+++ b/x11-base/xcb-proto/Manifest
@@ -1,2 +1,3 @@
DIST xcb-proto-1.14.1.tar.xz 143588 BLAKE2B 24983ec26632e93ef2d0c854cd41272925b6f3aab2642701232b73bc37d200d794c46f438e4a4102484e6ac9723e78c923b99cc78ada3541f43eaf0ad7ebc863 SHA512 140fbf48483bacc7f6b70fdcf76f9e4ff0e87df9cb3a071cea47d8fe4574407cdefcfbd674099014d297e5fc010748e71d8609fca4cc32e8b25c634f928b727d
+DIST xcb-proto-1.15.1.tar.xz 147908 BLAKE2B a85a40f725b4704f23a407862626b34cdaeaecb66877126dbbeadc6993da12a0687d9965d1e72144683e15be53b7fda151480cbe7e2caa572f3b029d9c45a416 SHA512 56fd505e567e1d39b4d46d0e5f79aeb90144c9b1a4429b2f51cd326ec0dea2a5fda5e2ebfe48af0da2781a4b1e29d9a91a4e0da662db5e35a701eac2e5ec1684
DIST xcb-proto-1.15.tar.xz 146628 BLAKE2B d7f38f1a415a7c70af372c64726e089ee454ffb981c031e4b8e93f345a1ada9dc40fb4e8b59adf553af8b4d9b7ef52730c9df56a0c24e53f98b3403346c7e810 SHA512 a333ac7c39f17ff2567419d09a9a77210c943a4e88d79eb152d416ae26bf6fb14e2446f9817abc806edd7aa3733bd4de5852b5ae90a25cbcc9d40e59c211aa36
diff --git a/x11-base/xcb-proto/xcb-proto-1.15.1.ebuild b/x11-base/xcb-proto/xcb-proto-1.15.1.ebuild
new file mode 100644
index 000000000000..6340da91f79c
--- /dev/null
+++ b/x11-base/xcb-proto/xcb-proto-1.15.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+XORG_TARBALL_SUFFIX="xz"
+XORG_MODULE=proto/
+XORG_MULTILIB=yes
+
+inherit python-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/proto/xcbproto"
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/xcbproto.git"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2
+"
+
+ECONF_SOURCE="${S}"
+
+multilib_src_configure() {
+ # Don't use Python to find sitedir here.
+ PYTHON=true default
+}
+
+src_compile() {
+ :
+}
+
+xcbgen_install() {
+ # Use eclass to find sitedir instead.
+ emake -C xcbgen install DESTDIR="${D}" pythondir="$(python_get_sitedir)"
+ python_optimize
+}
+
+multilib_src_install() {
+ # Restrict SUBDIRS to prevent xcbgen with empty sitedir.
+ emake install DESTDIR="${D}" SUBDIRS=src
+ multilib_is_native_abi && python_foreach_impl xcbgen_install
+}