summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/sipsak
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/sipsak')
-rw-r--r--net-misc/sipsak/Manifest1
-rw-r--r--net-misc/sipsak/files/0.9.6_p1-callback.patch12
-rw-r--r--net-misc/sipsak/metadata.xml10
-rw-r--r--net-misc/sipsak/sipsak-0.9.6_p1-r1.ebuild36
-rw-r--r--net-misc/sipsak/sipsak-0.9.6_p1.ebuild31
5 files changed, 90 insertions, 0 deletions
diff --git a/net-misc/sipsak/Manifest b/net-misc/sipsak/Manifest
new file mode 100644
index 000000000000..2aa07a19964d
--- /dev/null
+++ b/net-misc/sipsak/Manifest
@@ -0,0 +1 @@
+DIST sipsak-0.9.6-1.tar.gz 158776 SHA256 5064c56d482a080b6a4aea71821b78c21b59d44f6d1aa14c27429441917911a9 SHA512 c2d62ddaf2ecc9616941cf002a0494d2f9c43747e6b527f8b1542e9b5ae143fc69b18fc140bd3f255896b0e8eb02f7d198cc1799a4041e2d0c95d90b653591fe WHIRLPOOL 40c5f38c429703c0d3063c2c1bee8f0195b3fb0e1377b29350ef1b566c55960679292f245720d77203948111df8e3914b9cb82d4c6f4a74581d29f0403c02cb6
diff --git a/net-misc/sipsak/files/0.9.6_p1-callback.patch b/net-misc/sipsak/files/0.9.6_p1-callback.patch
new file mode 100644
index 000000000000..37dc486d3174
--- /dev/null
+++ b/net-misc/sipsak/files/0.9.6_p1-callback.patch
@@ -0,0 +1,12 @@
+diff -uNr sipsak-0.9.6.ORIG/helper.c sipsak-0.9.6/helper.c
+--- sipsak-0.9.6.ORIG/helper.c 2015-01-27 14:14:12.208729426 +0000
++++ sipsak-0.9.6/helper.c 2015-01-27 14:14:55.406728851 +0000
+@@ -250,7 +250,7 @@
+ return aptr;
+ }
+
+-static void cares_callback(void *arg, int status, unsigned char *abuf, int alen) {
++static void cares_callback(void *arg, int status, int timeouts, unsigned char *abuf, int alen) {
+ int i;
+ unsigned int ancount, nscount, arcount;
+ const unsigned char *aptr;
diff --git a/net-misc/sipsak/metadata.xml b/net-misc/sipsak/metadata.xml
new file mode 100644
index 000000000000..7e6b8b37f4a9
--- /dev/null
+++ b/net-misc/sipsak/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sipsak.berlios</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/sipsak/sipsak-0.9.6_p1-r1.ebuild b/net-misc/sipsak/sipsak-0.9.6_p1-r1.ebuild
new file mode 100644
index 000000000000..b0952f9ef018
--- /dev/null
+++ b/net-misc/sipsak/sipsak-0.9.6_p1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="small command line tool for testing SIP applications and devices"
+HOMEPAGE="http://sourceforge.net/projects/sipsak.berlios/"
+SRC_URI="mirror://sourceforge/sipsak.berlios/${P/_p/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="gnutls"
+
+RDEPEND="gnutls? ( net-libs/gnutls )
+ net-dns/c-ares"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P/_p1}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-callback.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable gnutls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/net-misc/sipsak/sipsak-0.9.6_p1.ebuild b/net-misc/sipsak/sipsak-0.9.6_p1.ebuild
new file mode 100644
index 000000000000..f1ebfd14cfbd
--- /dev/null
+++ b/net-misc/sipsak/sipsak-0.9.6_p1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="small command line tool for testing SIP applications and devices"
+HOMEPAGE="http://sipsak.org/"
+SRC_URI="mirror://berlios/sipsak/${P/_p/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86 ~x86-fbsd"
+IUSE="gnutls"
+
+RDEPEND="gnutls? ( net-libs/gnutls )
+ net-dns/c-ares"
+# ares? ( net-dns/c-ares )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P/_p1}
+
+src_configure() {
+ econf \
+ $(use_enable gnutls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}