summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-30 19:48:34 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-30 19:51:45 +0200
commitee582437824e80dc8ef4b5835a8d1da26515c055 (patch)
treea73fd5497ec6f924c0cbb1fc175ff13b0acb7234 /dev-python/py-ubjson
parentdev-python/python-snappy: Enable py3.13 (diff)
downloadgentoo-ee582437824e80dc8ef4b5835a8d1da26515c055.tar.gz
gentoo-ee582437824e80dc8ef4b5835a8d1da26515c055.tar.bz2
gentoo-ee582437824e80dc8ef4b5835a8d1da26515c055.zip
dev-python/py-ubjson: Deselect failing tests
Closes: https://bugs.gentoo.org/930272 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/py-ubjson')
-rw-r--r--dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild b/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
index d04531f7b07d..03a8d9bc4bf8 100644
--- a/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
+++ b/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,7 +20,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
PATCHES=(
# https://github.com/Iotic-Labs/py-ubjson/pull/19
@@ -28,5 +28,12 @@ PATCHES=(
)
python_test() {
- eunittest -s test
+ local EPYTEST_DESELECT=(
+ # the usual problem with random packages increasing recursion limit
+ test/test.py::TestEncodeDecodePlainExt::test_recursion
+ test/test.py::TestEncodeDecodeFpExt::test_recursion
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest test/test.py
}