summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild')
-rw-r--r--dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild b/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
index d04531f7b07d..03a8d9bc4bf8 100644
--- a/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
+++ b/dev-python/py-ubjson/py-ubjson-0.16.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,7 +20,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
PATCHES=(
# https://github.com/Iotic-Labs/py-ubjson/pull/19
@@ -28,5 +28,12 @@ PATCHES=(
)
python_test() {
- eunittest -s test
+ local EPYTEST_DESELECT=(
+ # the usual problem with random packages increasing recursion limit
+ test/test.py::TestEncodeDecodePlainExt::test_recursion
+ test/test.py::TestEncodeDecodeFpExt::test_recursion
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest test/test.py
}