summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-09 06:42:17 +0000
committerSam James <sam@gentoo.org>2022-11-09 06:53:31 +0000
commit742dc5d19dd0a6c824b7086437df3fad2e8f4603 (patch)
treebd27e2e58d1bebd8ffe67e87b93e4e6668bd17ed /dev-python/manuel/manuel-1.12.4.ebuild
parentdev-python/sybil: enable py3.11 (diff)
downloadgentoo-742dc5d19dd0a6c824b7086437df3fad2e8f4603.tar.gz
gentoo-742dc5d19dd0a6c824b7086437df3fad2e8f4603.tar.bz2
gentoo-742dc5d19dd0a6c824b7086437df3fad2e8f4603.zip
dev-python/manuel: enable py3.11
Thanks-to: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/manuel/manuel-1.12.4.ebuild')
-rw-r--r--dev-python/manuel/manuel-1.12.4.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/manuel/manuel-1.12.4.ebuild b/dev-python/manuel/manuel-1.12.4.ebuild
index 53d57dc4f904..51d2168b7d8b 100644
--- a/dev-python/manuel/manuel-1.12.4.ebuild
+++ b/dev-python/manuel/manuel-1.12.4.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -28,6 +28,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-tests-python311.patch
+)
+
distutils_enable_tests setup.py
src_prepare() {