summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-09 06:42:17 +0000
committerSam James <sam@gentoo.org>2022-11-09 06:53:31 +0000
commit742dc5d19dd0a6c824b7086437df3fad2e8f4603 (patch)
treebd27e2e58d1bebd8ffe67e87b93e4e6668bd17ed /dev-python/manuel
parentdev-python/sybil: enable py3.11 (diff)
downloadgentoo-742dc5d19dd0a6c824b7086437df3fad2e8f4603.tar.gz
gentoo-742dc5d19dd0a6c824b7086437df3fad2e8f4603.tar.bz2
gentoo-742dc5d19dd0a6c824b7086437df3fad2e8f4603.zip
dev-python/manuel: enable py3.11
Thanks-to: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/manuel')
-rw-r--r--dev-python/manuel/files/manuel-1.12.4-tests-python311.patch22
-rw-r--r--dev-python/manuel/manuel-1.12.4.ebuild6
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-python/manuel/files/manuel-1.12.4-tests-python311.patch b/dev-python/manuel/files/manuel-1.12.4-tests-python311.patch
new file mode 100644
index 000000000000..5a6ef9dc3b7d
--- /dev/null
+++ b/dev-python/manuel/files/manuel-1.12.4-tests-python311.patch
@@ -0,0 +1,22 @@
+https://github.com/benji-york/manuel/pull/32
+
+From d9f12d03e39bb76e4bb3ba43ad51af6d3e9d45c0 Mon Sep 17 00:00:00 2001
+From: Matt Jolly <Matt.Jolly@footclan.ninja>
+Date: Mon, 6 Jun 2022 22:44:22 +1000
+Subject: [PATCH] Replace TextTestResult with TestResult for Py3.11
+
+--- a/src/manuel/index.txt
++++ b/src/manuel/index.txt
+@@ -211,10 +211,7 @@ When tests are run this way:
+
+ >>> sys.stdout.writeln = lambda s: sys.stdout.write(s+'\n')
+ >>> suite = loader.loadTestsFromTestCase(MyTest)
+- >>> result = suite.run(unittest.TextTestResult(sys.stdout, True, 3))
+- test1 (tests.MyTest) ... ok
+- test2 (tests.MyTest) ... ok
+- test3 (tests.MyTest) ... FAIL
++ >>> result = suite.run(unittest.TestResult(True, 3))
+
+ >>> for _, e in result.errors:
+ ... print(e); print
+
diff --git a/dev-python/manuel/manuel-1.12.4.ebuild b/dev-python/manuel/manuel-1.12.4.ebuild
index 53d57dc4f904..51d2168b7d8b 100644
--- a/dev-python/manuel/manuel-1.12.4.ebuild
+++ b/dev-python/manuel/manuel-1.12.4.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -28,6 +28,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-tests-python311.patch
+)
+
distutils_enable_tests setup.py
src_prepare() {