summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-28 22:25:30 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-28 22:29:14 +0300
commit045b09b1bc1b16648aed6bb5acc349785c4bfbf0 (patch)
tree5c1b174acccf1ba1845de2eee7c50644a914e48e /dev-python/logical-unification
parentdev-python/toolz: enable py3.12 (diff)
downloadgentoo-045b09b1bc1b16648aed6bb5acc349785c4bfbf0.tar.gz
gentoo-045b09b1bc1b16648aed6bb5acc349785c4bfbf0.tar.bz2
gentoo-045b09b1bc1b16648aed6bb5acc349785c4bfbf0.zip
dev-python/logical-unification: enable py3.12
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/logical-unification')
-rw-r--r--dev-python/logical-unification/logical-unification-0.4.6.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/logical-unification/logical-unification-0.4.6.ebuild b/dev-python/logical-unification/logical-unification-0.4.6.ebuild
index a4d2f2079412..ef3038a1d16e 100644
--- a/dev-python/logical-unification/logical-unification-0.4.6.ebuild
+++ b/dev-python/logical-unification/logical-unification-0.4.6.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -33,4 +33,6 @@ distutils_enable_tests pytest
EPYTEST_DESELECT=(
tests/test_benchmarks.py
+ # weird test for testing limits of runtime
+ tests/test_core.py::test_reify_recursion_limit
)