summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-10-12 17:18:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-16 20:21:00 +0200
commit7f5791ae119a218f98b3832c7ee4ab6f62f1e3b2 (patch)
tree8160464a7a7e8fd45191bef414da754a4a01de29 /dev-python/HeapDict
parentdev-python/PyUtilib: correct DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-7f5791ae119a218f98b3832c7ee4ab6f62f1e3b2.tar.gz
gentoo-7f5791ae119a218f98b3832c7ee4ab6f62f1e3b2.tar.bz2
gentoo-7f5791ae119a218f98b3832c7ee4ab6f62f1e3b2.zip
dev-python/HeapDict: correct DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/747994 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/HeapDict')
-rw-r--r--dev-python/HeapDict/HeapDict-1.0.0.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/dev-python/HeapDict/HeapDict-1.0.0.ebuild b/dev-python/HeapDict/HeapDict-1.0.0.ebuild
index 2bb62012b4d1..ed316918da26 100644
--- a/dev-python/HeapDict/HeapDict-1.0.0.ebuild
+++ b/dev-python/HeapDict/HeapDict-1.0.0.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -13,7 +15,3 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"