summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-23 14:48:40 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-23 14:52:08 -0500
commitb17c2c4f8a7fe2808c0f31c8d37ad82f199f5d28 (patch)
treecf7edd81fe122cef49c8bfab7420e27ddee1d242 /dev-lang/open-cobol
parentmedia-libs/cogl: Add patch to build with mesa-19.3 (diff)
downloadgentoo-b17c2c4f8a7fe2808c0f31c8d37ad82f199f5d28.tar.gz
gentoo-b17c2c4f8a7fe2808c0f31c8d37ad82f199f5d28.tar.bz2
gentoo-b17c2c4f8a7fe2808c0f31c8d37ad82f199f5d28.zip
dev-lang/open-cobol: bump EAPI and stuff
* bump EAPI to 7 * Fix HOMEPAGE * Use MY_PN to future proof if maintainer or p-m want to bump to GnuCOBOL * License remains the same unless pkgmove is done * Use src_configure and remove other unneeded stuff Bug: https://bugs.gentoo.org/641888 Bug: https://bugs.gentoo.org/685960 Closes: https://bugs.gentoo.org/697350 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-lang/open-cobol')
-rw-r--r--dev-lang/open-cobol/open-cobol-1.1.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/dev-lang/open-cobol/open-cobol-1.1.ebuild b/dev-lang/open-cobol/open-cobol-1.1.ebuild
index a34d440d937b..83ba13532f67 100644
--- a/dev-lang/open-cobol/open-cobol-1.1.ebuild
+++ b/dev-lang/open-cobol/open-cobol-1.1.ebuild
@@ -1,35 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils
+MY_PN="open-cobol"
+# Future proof pkg if maintainer or p-m want to bump to latest GNUCobol
DESCRIPTION="an open-source COBOL compiler"
-HOMEPAGE="http://www.opencobol.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="https://sourceforge.net/projects/open-cobol/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
+# License must be changed to GPL-3+ if/when pkgmove is done
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="berkdb nls readline"
-RDEPEND="dev-libs/gmp
- berkdb? ( =sys-libs/db-4* )
+RDEPEND="dev-libs/gmp:0=
+ berkdb? ( sys-libs/db:4.8= )
sys-libs/ncurses
readline? ( sys-libs/readline )"
DEPEND="${RDEPEND}
sys-devel/libtool"
-src_compile() {
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
econf \
$(use_with berkdb db) \
$(use_enable nls) \
- $(use_with readline) || die "econf failed."
- emake || die "emake failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog NEWS README
+ $(use_with readline)
+ default
}