summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/open-cobol/open-cobol-1.1.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/dev-lang/open-cobol/open-cobol-1.1.ebuild b/dev-lang/open-cobol/open-cobol-1.1.ebuild
index a34d440d937b..83ba13532f67 100644
--- a/dev-lang/open-cobol/open-cobol-1.1.ebuild
+++ b/dev-lang/open-cobol/open-cobol-1.1.ebuild
@@ -1,35 +1,34 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils
+MY_PN="open-cobol"
+# Future proof pkg if maintainer or p-m want to bump to latest GNUCobol
DESCRIPTION="an open-source COBOL compiler"
-HOMEPAGE="http://www.opencobol.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="https://sourceforge.net/projects/open-cobol/"
+SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
+# License must be changed to GPL-3+ if/when pkgmove is done
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="berkdb nls readline"
-RDEPEND="dev-libs/gmp
- berkdb? ( =sys-libs/db-4* )
+RDEPEND="dev-libs/gmp:0=
+ berkdb? ( sys-libs/db:4.8= )
sys-libs/ncurses
readline? ( sys-libs/readline )"
DEPEND="${RDEPEND}
sys-devel/libtool"
-src_compile() {
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
econf \
$(use_with berkdb db) \
$(use_enable nls) \
- $(use_with readline) || die "econf failed."
- emake || die "emake failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog NEWS README
+ $(use_with readline)
+ default
}