summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrii Kurdiumov <kant2002@gmail.com>2021-12-04 23:31:56 +0600
committerZac Medico <zmedico@gentoo.org>2021-12-04 12:07:48 -0800
commitb8c18f5e5717d32105547c60950e1e4925b797f7 (patch)
tree87d2c08a64f95b464bab79d7c2364e8b19f0a1a4 /dev-dotnet
parentsys-libs/libucontext: override arch detection for e.g. x86 (diff)
downloadgentoo-b8c18f5e5717d32105547c60950e1e4925b797f7.tar.gz
gentoo-b8c18f5e5717d32105547c60950e1e4925b797f7.tar.bz2
gentoo-b8c18f5e5717d32105547c60950e1e4925b797f7.zip
dev-dotnet/dotnet-sdk-bin: Add workload definition for 6.0.100
Add /opt/dotnet-sdk-bin-6.0/metadata/workloads/6.0.100/userlocal file which used to indicate which workloads are installed. Without that file Nuget think this is broken installation and attempt to create that file which become a problem for ebuilds which depends on dotnet. See: https://github.com/dotnet/sdk/pull/18823#issuecomment-915603684 Closes: https://github.com/gentoo/gentoo/pull/23182 Closes: https://bugs.gentoo.org/827712 Signed-off-by: Andrii Kurdiumov <kant2002@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild
index 8f0c1a6de55f..a52d40cfec34 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild
@@ -37,6 +37,12 @@ src_install() {
local dest="opt/${PN}-${SLOT}"
dodir "${dest%/*}"
+ # 6.0.100 is SDK feature band which will not change between minor increases, so 6.0.101, 6.102
+ # will still have same 6.0.100 SDK feature band in the name. Thus I have to hard code this
+ # https://github.com/dotnet/sdk/pull/18823#issuecomment-915603684
+ local workloads="metadata/workloads/${SLOT}.100"
+
+ { mkdir -p "${S}/${workloads}" && touch "${S}/${workloads}/userlocal"; } || die
{ mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"