summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild
index 8f0c1a6de55f..a52d40cfec34 100644
--- a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild
@@ -37,6 +37,12 @@ src_install() {
local dest="opt/${PN}-${SLOT}"
dodir "${dest%/*}"
+ # 6.0.100 is SDK feature band which will not change between minor increases, so 6.0.101, 6.102
+ # will still have same 6.0.100 SDK feature band in the name. Thus I have to hard code this
+ # https://github.com/dotnet/sdk/pull/18823#issuecomment-915603684
+ local workloads="metadata/workloads/${SLOT}.100"
+
+ { mkdir -p "${S}/${workloads}" && touch "${S}/${workloads}/userlocal"; } || die
{ mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"