summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-13 02:58:55 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-13 03:41:11 -0700
commitdb01e788666a794dd6746686a7810efe59b75816 (patch)
tree9bb649ebf3bf18344af5f03c20b77b8e4c023a6b /app-emulation
parentAdd CPE tag for app-emulation/runc. (diff)
downloadgentoo-db01e788666a794dd6746686a7810efe59b75816.tar.gz
gentoo-db01e788666a794dd6746686a7810efe59b75816.tar.bz2
gentoo-db01e788666a794dd6746686a7810efe59b75816.zip
app-emulation/runc: fix variables
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/runc/runc-1.0.0_rc10-r1.ebuild14
-rw-r--r--app-emulation/runc/runc-1.0.0_rc92.ebuild14
-rw-r--r--app-emulation/runc/runc-1.0.0_rc93.ebuild16
3 files changed, 25 insertions, 19 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild b/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
index 9f60bd86db13..0a433baafd1e 100644
--- a/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
+++ b/app-emulation/runc/runc-1.0.0_rc10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,9 +40,9 @@ RESTRICT+=" test"
src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ROOT}/usr/$(get_libdir)"
+ -L${ESYSROOT}/usr/$(get_libdir)"
# build up optional flags
local options=(
@@ -54,11 +54,8 @@ src_compile() {
)
myemakeargs=(
- BINDIR="${ED}/usr/bin"
BUILDTAGS="${options[*]}"
COMMIT=${RUNC_COMMIT}
- DESTDIR="${ED}"
- PREFIX="${ED}/usr"
GOPATH="${S}"
-C "src/${EGO_PN}"
)
@@ -67,6 +64,11 @@ src_compile() {
}
src_install() {
+ myemakeargs+=(
+ PREFIX="${ED}/usr"
+ BINDIR="${ED}/usr/bin"
+ MANDIR="${ED}/usr/share/man"
+ )
emake "${myemakeargs[@]}" install install-man install-bash
local DOCS=( src/"${EGO_PN}"/{README.md,PRINCIPLES.md,docs/.} )
diff --git a/app-emulation/runc/runc-1.0.0_rc92.ebuild b/app-emulation/runc/runc-1.0.0_rc92.ebuild
index fe79682ba080..35e4c457ae5b 100644
--- a/app-emulation/runc/runc-1.0.0_rc92.ebuild
+++ b/app-emulation/runc/runc-1.0.0_rc92.ebuild
@@ -42,9 +42,9 @@ S="${WORKDIR}/${PN}-${MY_PV}"
src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ROOT}/usr/$(get_libdir)"
+ -L${ESYSROOT}/usr/$(get_libdir)"
# build up optional flags
local options=(
@@ -56,17 +56,19 @@ src_compile() {
)
myemakeargs=(
- BINDIR="${ED}/usr/bin"
BUILDTAGS="${options[*]}"
- COMMIT=${RUNC_COMMIT}
- DESTDIR="${ED}"
- PREFIX="${ED}/usr"
+ COMMIT="${RUNC_COMMIT}"
)
emake "${myemakeargs[@]}" runc man
}
src_install() {
+ myemakeargs+=(
+ PREFIX="${ED}/usr"
+ BINDIR="${ED}/usr/bin"
+ MANDIR="${ED}/usr/share/man"
+ )
emake "${myemakeargs[@]}" install install-man install-bash
local DOCS=( README.md PRINCIPLES.md docs/. )
diff --git a/app-emulation/runc/runc-1.0.0_rc93.ebuild b/app-emulation/runc/runc-1.0.0_rc93.ebuild
index f89d4a1ce278..316f720fc29c 100644
--- a/app-emulation/runc/runc-1.0.0_rc93.ebuild
+++ b/app-emulation/runc/runc-1.0.0_rc93.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -42,9 +42,9 @@ S="${WORKDIR}/${PN}-${MY_PV}"
src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ROOT}/usr/$(get_libdir)"
+ -L${ESYSROOT}/usr/$(get_libdir)"
# build up optional flags
local options=(
@@ -54,17 +54,19 @@ src_compile() {
)
myemakeargs=(
- BINDIR="/usr/bin"
BUILDTAGS="${options[*]}"
- COMMIT=${RUNC_COMMIT}
- DESTDIR="${ED}"
- PREFIX="/usr"
+ COMMIT="${RUNC_COMMIT}"
)
emake "${myemakeargs[@]}" runc man
}
src_install() {
+ myemakeargs+=(
+ PREFIX="${ED}/usr"
+ BINDIR="${ED}/usr/bin"
+ MANDIR="${ED}/usr/share/man"
+ )
emake "${myemakeargs[@]}" install install-man install-bash
local DOCS=( README.md PRINCIPLES.md docs/. )