summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/runc/runc-1.0.0_rc92.ebuild')
-rw-r--r--app-emulation/runc/runc-1.0.0_rc92.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc92.ebuild b/app-emulation/runc/runc-1.0.0_rc92.ebuild
index fe79682ba080..35e4c457ae5b 100644
--- a/app-emulation/runc/runc-1.0.0_rc92.ebuild
+++ b/app-emulation/runc/runc-1.0.0_rc92.ebuild
@@ -42,9 +42,9 @@ S="${WORKDIR}/${PN}-${MY_PV}"
src_compile() {
# Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_CFLAGS="-I${ESYSROOT}/usr/include"
export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ROOT}/usr/$(get_libdir)"
+ -L${ESYSROOT}/usr/$(get_libdir)"
# build up optional flags
local options=(
@@ -56,17 +56,19 @@ src_compile() {
)
myemakeargs=(
- BINDIR="${ED}/usr/bin"
BUILDTAGS="${options[*]}"
- COMMIT=${RUNC_COMMIT}
- DESTDIR="${ED}"
- PREFIX="${ED}/usr"
+ COMMIT="${RUNC_COMMIT}"
)
emake "${myemakeargs[@]}" runc man
}
src_install() {
+ myemakeargs+=(
+ PREFIX="${ED}/usr"
+ BINDIR="${ED}/usr/bin"
+ MANDIR="${ED}/usr/share/man"
+ )
emake "${myemakeargs[@]}" install install-man install-bash
local DOCS=( README.md PRINCIPLES.md docs/. )