summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-30 07:13:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-30 07:45:33 +0200
commit188f726d3471bb3313b9b28fcc450f9ea5cf25b3 (patch)
treed82658e0ae489b7a614c10d299e5c2aee9dd8f5e /app-arch/lz4/lz4-1.9.4.ebuild
parentapp-arch/xarchiver: Bump to 0.5.4.19 (diff)
downloadgentoo-188f726d3471bb3313b9b28fcc450f9ea5cf25b3.tar.gz
gentoo-188f726d3471bb3313b9b28fcc450f9ea5cf25b3.tar.bz2
gentoo-188f726d3471bb3313b9b28fcc450f9ea5cf25b3.zip
app-arch/lz4: Bump to 1.9.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/lz4/lz4-1.9.4.ebuild')
-rw-r--r--app-arch/lz4/lz4-1.9.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/lz4/lz4-1.9.4.ebuild b/app-arch/lz4/lz4-1.9.4.ebuild
new file mode 100644
index 000000000000..8b9add9dbac7
--- /dev/null
+++ b/app-arch/lz4/lz4-1.9.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://github.com/lz4/lz4"
+SRC_URI="https://github.com/lz4/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+# https://abi-laboratory.pro/tracker/timeline/lz4/
+SLOT="0/r132"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+CMAKE_USE_DIR=${S}/build/cmake
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ )
+
+ cmake_src_configure
+}