summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-30 07:13:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-30 07:45:33 +0200
commit188f726d3471bb3313b9b28fcc450f9ea5cf25b3 (patch)
treed82658e0ae489b7a614c10d299e5c2aee9dd8f5e /app-arch/lz4
parentapp-arch/xarchiver: Bump to 0.5.4.19 (diff)
downloadgentoo-188f726d3471bb3313b9b28fcc450f9ea5cf25b3.tar.gz
gentoo-188f726d3471bb3313b9b28fcc450f9ea5cf25b3.tar.bz2
gentoo-188f726d3471bb3313b9b28fcc450f9ea5cf25b3.zip
app-arch/lz4: Bump to 1.9.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/lz4')
-rw-r--r--app-arch/lz4/Manifest1
-rw-r--r--app-arch/lz4/lz4-1.9.4.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-arch/lz4/Manifest b/app-arch/lz4/Manifest
index c60a5c0d8da5..835409a3a225 100644
--- a/app-arch/lz4/Manifest
+++ b/app-arch/lz4/Manifest
@@ -1 +1,2 @@
DIST lz4-1.9.3.tar.gz 320958 BLAKE2B 9a194bd18ff52f780aa03a8a53fe7fab7b58117d768f4ba8e5005830c935d16328d0f7cc54f9413b58faf245017c0ac85fb4e709a9db150cb150a0a2a3c21645 SHA512 c246b0bda881ee9399fa1be490fa39f43b291bb1d9db72dba8a85db1a50aad416a97e9b300eee3d2a4203c2bd88bda2762e81bc229c3aa409ad217eb306a454c
+DIST lz4-1.9.4.tar.gz 354063 BLAKE2B 2289cdce36acd35283bf2f02ef4d6d8f4805563be6d5a3492f3d6ea7975fb6bd14e1ac2e505df9747776edf8bcf0da7ba4ae7084b150e3ec08a52a9885f92ad5 SHA512 043a9acb2417624019d73db140d83b80f1d7c43a6fd5be839193d68df8fd0b3f610d7ed4d628c2a9184f7cde9a0fd1ba9d075d8251298e3eb4b3a77f52736684
diff --git a/app-arch/lz4/lz4-1.9.4.ebuild b/app-arch/lz4/lz4-1.9.4.ebuild
new file mode 100644
index 000000000000..8b9add9dbac7
--- /dev/null
+++ b/app-arch/lz4/lz4-1.9.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://github.com/lz4/lz4"
+SRC_URI="https://github.com/lz4/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-2"
+# https://abi-laboratory.pro/tracker/timeline/lz4/
+SLOT="0/r132"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+CMAKE_USE_DIR=${S}/build/cmake
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ )
+
+ cmake_src_configure
+}