aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYingChi Long <me@inclyc.cn>2022-08-26 20:50:17 +0800
committerYingChi Long <me@inclyc.cn>2022-08-26 20:52:29 +0800
commita3f8536775b50db8c490d63db53e257b56165b9b (patch)
treea7e84e61560e19f5d8ae5676b67e8b69d28d20c2 /dev-util/xmake/xmake-2.7.1.ebuild
parentapp-vim/kotlin-vim: fix manifest (diff)
downloadguru-a3f8536775b50db8c490d63db53e257b56165b9b.tar.gz
guru-a3f8536775b50db8c490d63db53e257b56165b9b.tar.bz2
guru-a3f8536775b50db8c490d63db53e257b56165b9b.zip
dev-util/xmake: new package, add 2.7.1, 9999
Signed-off-by: YingChi Long <me@inclyc.cn>
Diffstat (limited to 'dev-util/xmake/xmake-2.7.1.ebuild')
-rw-r--r--dev-util/xmake/xmake-2.7.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/xmake/xmake-2.7.1.ebuild b/dev-util/xmake/xmake-2.7.1.ebuild
new file mode 100644
index 000000000..d2044cf5f
--- /dev/null
+++ b/dev-util/xmake/xmake-2.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature
+
+DESCRIPTION="A cross-platform build utility based on Lua."
+HOMEPAGE="https://xmake.io"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/xmake-io/${PN}.git"
+else
+ SRC_URI="https://github.com/xmake-io/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+ # extraction path may change in future
+ S="${WORKDIR}"
+fi
+
+# tarball doesn't provide tests
+RESTRICT="test"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ virtual/pkgconfig
+ sys-libs/ncurses
+ sys-libs/readline
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+DOCS=(
+ CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md
+ NOTICE.md README.md README_zh.md
+)
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ einstalldocs
+
+ emake PREFIX="/usr" DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ optfeature "cached compilation for your xmake projects" dev-util/ccache
+}