aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYingChi Long <me@inclyc.cn>2022-08-26 20:50:17 +0800
committerYingChi Long <me@inclyc.cn>2022-08-26 20:52:29 +0800
commita3f8536775b50db8c490d63db53e257b56165b9b (patch)
treea7e84e61560e19f5d8ae5676b67e8b69d28d20c2 /dev-util
parentapp-vim/kotlin-vim: fix manifest (diff)
downloadguru-a3f8536775b50db8c490d63db53e257b56165b9b.tar.gz
guru-a3f8536775b50db8c490d63db53e257b56165b9b.tar.bz2
guru-a3f8536775b50db8c490d63db53e257b56165b9b.zip
dev-util/xmake: new package, add 2.7.1, 9999
Signed-off-by: YingChi Long <me@inclyc.cn>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/xmake/Manifest1
-rw-r--r--dev-util/xmake/metadata.xml18
-rw-r--r--dev-util/xmake/xmake-2.7.1.ebuild51
-rw-r--r--dev-util/xmake/xmake-9999.ebuild51
4 files changed, 121 insertions, 0 deletions
diff --git a/dev-util/xmake/Manifest b/dev-util/xmake/Manifest
new file mode 100644
index 000000000..1aba9b603
--- /dev/null
+++ b/dev-util/xmake/Manifest
@@ -0,0 +1 @@
+DIST xmake-v2.7.1.tar.gz 4344324 BLAKE2B 6baec6724f4489f0abe25a5925f87fd952fd59645696014ffe23d33df98e838c7ef53fc948ca4d17feed6063da532fa2a59c691dd76305840f476e5e8f3407bb SHA512 499d1d4ac53b8189d8f68706b45981dd9a3c62018000291616a281b944fedb9d5802502dd9edfb7bc0ee5f0456b839f9f2605d536543994bdfb72d178024742e
diff --git a/dev-util/xmake/metadata.xml b/dev-util/xmake/metadata.xml
new file mode 100644
index 000000000..8181c8932
--- /dev/null
+++ b/dev-util/xmake/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <bugs-to>https://github.com/xmake-io/xmake/issues</bugs-to>
+ <remote-id type="github">xmake-io/xmake</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ xmake is a lightweight cross-platform build utility based on Lua. It uses
+ xmake.lua to maintain project builds. Compared with makefile/CMakeLists.txt,
+ the configuration syntax is more concise and intuitive. It is very friendly
+ to novices and can quickly get started in a short time. Let users focus more
+ on actual project development.
+ It can compile the project directly like Make/Ninja, or generate project
+ files like CMake/Meson, and it also has a built-in package management system
+ to help users solve the integrated use of C/C++ dependent libraries.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-util/xmake/xmake-2.7.1.ebuild b/dev-util/xmake/xmake-2.7.1.ebuild
new file mode 100644
index 000000000..d2044cf5f
--- /dev/null
+++ b/dev-util/xmake/xmake-2.7.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature
+
+DESCRIPTION="A cross-platform build utility based on Lua."
+HOMEPAGE="https://xmake.io"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/xmake-io/${PN}.git"
+else
+ SRC_URI="https://github.com/xmake-io/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+ # extraction path may change in future
+ S="${WORKDIR}"
+fi
+
+# tarball doesn't provide tests
+RESTRICT="test"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ virtual/pkgconfig
+ sys-libs/ncurses
+ sys-libs/readline
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+DOCS=(
+ CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md
+ NOTICE.md README.md README_zh.md
+)
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ einstalldocs
+
+ emake PREFIX="/usr" DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ optfeature "cached compilation for your xmake projects" dev-util/ccache
+}
diff --git a/dev-util/xmake/xmake-9999.ebuild b/dev-util/xmake/xmake-9999.ebuild
new file mode 100644
index 000000000..7671f4b44
--- /dev/null
+++ b/dev-util/xmake/xmake-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="A cross-platform build utility based on Lua."
+HOMEPAGE="https://xmake.io"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/xmake-io/${PN}.git"
+else
+ SRC_URI="https://github.com/xmake-io/${PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+ # extraction path may change in future
+ S="${WORKDIR}"
+fi
+
+# tarball doesn't provide tests
+RESTRICT="test"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ virtual/pkgconfig
+ sys-libs/ncurses
+ sys-libs/readline
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+DOCS=(
+ CHANGELOG.md CODE_OF_CONDUCT.md CONTRIBUTING.md
+ NOTICE.md README.md README_zh.md
+)
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ einstalldocs
+
+ emake PREFIX="/usr" DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ optfeature "cached compilation for your xmake projects" dev-util/ccache
+}