summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/rb_libtorrent/files')
-rw-r--r--net-libs/rb_libtorrent/files/rb_libtorrent-0.16.17-python.patch37
-rw-r--r--net-libs/rb_libtorrent/files/rb_libtorrent-1.0.2-python.patch32
2 files changed, 69 insertions, 0 deletions
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-0.16.17-python.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-0.16.17-python.patch
new file mode 100644
index 000000000000..6f8432040842
--- /dev/null
+++ b/net-libs/rb_libtorrent/files/rb_libtorrent-0.16.17-python.patch
@@ -0,0 +1,37 @@
+ bindings/python/setup.py.in | 6 +++---
+ configure.ac | 4 ----
+ 2 files changed, 3 insertions(+), 7 deletions(-)
+
+diff --git a/bindings/python/setup.py.in b/bindings/python/setup.py.in
+index adc474c..3faf982 100644
+--- a/bindings/python/setup.py.in
++++ b/bindings/python/setup.py.in
+@@ -61,10 +61,10 @@ if "CFLAGS" in config_vars and "-Wstrict-prototypes" in config_vars["CFLAGS"]:
+ if "OPT" in config_vars and "-Wstrict-prototypes" in config_vars["OPT"]:
+ config_vars["OPT"] = config_vars["OPT"].replace("-Wstrict-prototypes", " ")
+
+-source_list = os.listdir(os.path.join(os.path.dirname(__file__), "src"))
+-source_list = [os.path.join("src", s) for s in source_list if s.endswith(".cpp")]
++source_list = os.listdir(os.path.join('@srcdir@', "src"))
++source_list = [os.path.join('@srcdir@', "src", s) for s in source_list if s.endswith(".cpp")]
+
+-extra_cmd = '@COMPILETIME_OPTIONS@ @CPPFLAGS@ @LIBS@ @BOOST_SYSTEM_LIB@ @BOOST_PYTHON_LIB@ @PTHREAD_LIBS@ @OPENSSL_LIBS@ @OPENSSL_LDFLAGS@ @OPENSSL_INCLUDES@'
++extra_cmd = '@COMPILETIME_OPTIONS@ @CPPFLAGS@ @LIBS@ @BOOST_SYSTEM_LIB@ @PTHREAD_LIBS@ @OPENSSL_LIBS@ @OPENSSL_LDFLAGS@ @OPENSSL_INCLUDES@' + '-lboost_python-%s-mt' % (platform.python_version()[:3])
+
+ setup( name='python-libtorrent',
+ version='@PACKAGE_VERSION@',
+diff --git a/configure.ac b/configure.ac
+index 55ee13a..bdbf2a3 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -559,10 +559,6 @@ AS_CASE(["$ARG_ENABLE_PYTHON_BINDING"],
+
+ AM_PATH_PYTHON([2.4], [], AC_MSG_ERROR([Python interpreter not found.]))
+ AX_PYTHON_DEVEL([>= '2.4'])
+- AX_BOOST_PYTHON()
+-
+- AS_IF([test -z "$BOOST_PYTHON_LIB"],
+- [AC_MSG_ERROR([Boost.Python library not found. Try using --with-boost-python=lib.])])
+ ],
+ ["no"], [
+ AC_MSG_RESULT([no])
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.2-python.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.2-python.patch
new file mode 100644
index 000000000000..e729a190c79a
--- /dev/null
+++ b/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.2-python.patch
@@ -0,0 +1,32 @@
+ bindings/python/setup.py | 2 +-
+ configure.ac | 4 ----
+ 2 files changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/bindings/python/setup.py b/bindings/python/setup.py
+index 961395f..c38ef52 100644
+--- a/bindings/python/setup.py
++++ b/bindings/python/setup.py
+@@ -36,7 +36,7 @@ def target_specific():
+
+ try:
+ with open('compile_flags') as _file:
+- extra_cmd = _file.read()
++ extra_cmd = _file.read() + '-lboost_python-%s-mt' % (platform.python_version()[:3])
+
+ except:
+ extra_cmd = None
+diff --git a/configure.ac b/configure.ac
+index ebb1f7e..3e07828 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -540,10 +540,6 @@ AS_CASE(["$ARG_ENABLE_PYTHON_BINDING"],
+
+ AM_PATH_PYTHON([2.4], [], AC_MSG_ERROR([Python interpreter not found.]))
+ AX_PYTHON_DEVEL([>= '2.4'])
+- AX_BOOST_PYTHON()
+-
+- AS_IF([test -z "$BOOST_PYTHON_LIB"],
+- [AC_MSG_ERROR([Boost.Python library not found. Try using --with-boost-python=lib.])])
+ ],
+ ["no"], [
+ AC_MSG_RESULT([no])