summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/rb_libtorrent/files/rb_libtorrent-1.0.2-python.patch')
-rw-r--r--net-libs/rb_libtorrent/files/rb_libtorrent-1.0.2-python.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.2-python.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.2-python.patch
new file mode 100644
index 000000000000..e729a190c79a
--- /dev/null
+++ b/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.2-python.patch
@@ -0,0 +1,32 @@
+ bindings/python/setup.py | 2 +-
+ configure.ac | 4 ----
+ 2 files changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/bindings/python/setup.py b/bindings/python/setup.py
+index 961395f..c38ef52 100644
+--- a/bindings/python/setup.py
++++ b/bindings/python/setup.py
+@@ -36,7 +36,7 @@ def target_specific():
+
+ try:
+ with open('compile_flags') as _file:
+- extra_cmd = _file.read()
++ extra_cmd = _file.read() + '-lboost_python-%s-mt' % (platform.python_version()[:3])
+
+ except:
+ extra_cmd = None
+diff --git a/configure.ac b/configure.ac
+index ebb1f7e..3e07828 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -540,10 +540,6 @@ AS_CASE(["$ARG_ENABLE_PYTHON_BINDING"],
+
+ AM_PATH_PYTHON([2.4], [], AC_MSG_ERROR([Python interpreter not found.]))
+ AX_PYTHON_DEVEL([>= '2.4'])
+- AX_BOOST_PYTHON()
+-
+- AS_IF([test -z "$BOOST_PYTHON_LIB"],
+- [AC_MSG_ERROR([Boost.Python library not found. Try using --with-boost-python=lib.])])
+ ],
+ ["no"], [
+ AC_MSG_RESULT([no])