summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiosqlite/aiosqlite-0.18.0.ebuild')
-rw-r--r--dev-python/aiosqlite/aiosqlite-0.18.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/aiosqlite/aiosqlite-0.18.0.ebuild b/dev-python/aiosqlite/aiosqlite-0.18.0.ebuild
new file mode 100644
index 000000000000..507cc02a42a9
--- /dev/null
+++ b/dev-python/aiosqlite/aiosqlite-0.18.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517=flit
+inherit distutils-r1
+
+DESCRIPTION="asyncio bridge to the standard sqlite3 module"
+HOMEPAGE="
+ https://aiosqlite.omnilib.dev
+ https://pypi.org/project/aiosqlite/
+ https://github.com/omnilib/aiosqlite
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+# AttributeError: 'str' object has no attribute 'supported'
+#distutils_enable_sphinx docs dev-python/m2r