summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-07 21:47:50 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-07 22:38:18 +0100
commit1fb1f875b13c6f3e8891914c4fefca3d23659ac7 (patch)
tree676c1bc81d264c8ff9e1a189ea02884c050c37e3 /dev-python/aiosqlite/aiosqlite-0.18.0.ebuild
parentdev-python/y-py: new package, add 0.5.5 (diff)
downloadgentoo-1fb1f875b13c6f3e8891914c4fefca3d23659ac7.tar.gz
gentoo-1fb1f875b13c6f3e8891914c4fefca3d23659ac7.tar.bz2
gentoo-1fb1f875b13c6f3e8891914c4fefca3d23659ac7.zip
dev-python/aiosqlite: new package, add 0.18.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/aiosqlite/aiosqlite-0.18.0.ebuild')
-rw-r--r--dev-python/aiosqlite/aiosqlite-0.18.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/aiosqlite/aiosqlite-0.18.0.ebuild b/dev-python/aiosqlite/aiosqlite-0.18.0.ebuild
new file mode 100644
index 000000000000..507cc02a42a9
--- /dev/null
+++ b/dev-python/aiosqlite/aiosqlite-0.18.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517=flit
+inherit distutils-r1
+
+DESCRIPTION="asyncio bridge to the standard sqlite3 module"
+HOMEPAGE="
+ https://aiosqlite.omnilib.dev
+ https://pypi.org/project/aiosqlite/
+ https://github.com/omnilib/aiosqlite
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest
+
+# AttributeError: 'str' object has no attribute 'supported'
+#distutils_enable_sphinx docs dev-python/m2r