summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/redis')
-rw-r--r--dev-db/redis/redis-6.0.16.ebuild10
-rw-r--r--dev-db/redis/redis-6.2.6.ebuild10
-rw-r--r--dev-db/redis/redis-6.2.7-r1.ebuild10
-rw-r--r--dev-db/redis/redis-7.0.0-r1.ebuild16
-rw-r--r--dev-db/redis/redis-7.0.0.ebuild16
-rw-r--r--dev-db/redis/redis-7.0.1.ebuild16
6 files changed, 54 insertions, 24 deletions
diff --git a/dev-db/redis/redis-6.0.16.ebuild b/dev-db/redis/redis-6.0.16.ebuild
index 557648cfd6f1..f59c867797b2 100644
--- a/dev-db/redis/redis-6.0.16.ebuild
+++ b/dev-db/redis/redis-6.0.16.ebuild
@@ -140,10 +140,12 @@ src_test() {
--skiptest "Active defrag edge case"
)
- # Known to fail with FEATURES=usersandbox
- if has usersandbox ${FEATURES}; then
- ewarn "You are emerging ${P} with 'usersandbox' enabled." \
- "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ if has usersandbox ${FEATURES} || ! has userpriv ${FEATURES}; then
+ ewarn "unit/oom-score-adj test will be skipped." \
+ "It is known to fail with FEATURES usersandbox or -userpriv. See bug #756382."
+
+ # unit/oom-score-adj was introduced in version 6.2.0 and it was later backported to 6.0.7
+ runtestargs+=( --skipunit unit/oom-score-adj ) # see bug #756382
fi
if use ssl; then
diff --git a/dev-db/redis/redis-6.2.6.ebuild b/dev-db/redis/redis-6.2.6.ebuild
index f1a8a0d2cc41..2fe6b97c0f65 100644
--- a/dev-db/redis/redis-6.2.6.ebuild
+++ b/dev-db/redis/redis-6.2.6.ebuild
@@ -134,10 +134,12 @@ src_test() {
--clients "$(makeopts_jobs)" # see bug #649868
)
- # Known to fail with FEATURES=usersandbox
- if has usersandbox ${FEATURES}; then
- ewarn "You are emerging ${P} with 'usersandbox' enabled." \
- "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ if has usersandbox ${FEATURES} || ! has userpriv ${FEATURES}; then
+ ewarn "unit/oom-score-adj test will be skipped." \
+ "It is known to fail with FEATURES usersandbox or -userpriv. See bug #756382."
+
+ # unit/oom-score-adj was introduced in version 6.2.0
+ runtestargs+=( --skipunit unit/oom-score-adj ) # see bug #756382
fi
if use ssl; then
diff --git a/dev-db/redis/redis-6.2.7-r1.ebuild b/dev-db/redis/redis-6.2.7-r1.ebuild
index 7c3fb2239fa5..a15818f6a3db 100644
--- a/dev-db/redis/redis-6.2.7-r1.ebuild
+++ b/dev-db/redis/redis-6.2.7-r1.ebuild
@@ -136,10 +136,12 @@ src_test() {
--clients "$(makeopts_jobs)" # see bug #649868
)
- # Known to fail with FEATURES=usersandbox
- if has usersandbox ${FEATURES}; then
- ewarn "You are emerging ${P} with 'usersandbox' enabled." \
- "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ if has usersandbox ${FEATURES} || ! has userpriv ${FEATURES}; then
+ ewarn "unit/oom-score-adj test will be skipped." \
+ "It is known to fail with FEATURES usersandbox or -userpriv. See bug #756382."
+
+ # unit/oom-score-adj was introduced in version 6.2.0
+ runtestargs+=( --skipunit unit/oom-score-adj ) # see bug #756382
fi
if use ssl; then
diff --git a/dev-db/redis/redis-7.0.0-r1.ebuild b/dev-db/redis/redis-7.0.0-r1.ebuild
index 0de72a51722e..180394de9ee9 100644
--- a/dev-db/redis/redis-7.0.0-r1.ebuild
+++ b/dev-db/redis/redis-7.0.0-r1.ebuild
@@ -117,10 +117,18 @@ src_test() {
--clients "$(makeopts_jobs)" # see bug #649868
)
- # Known to fail with FEATURES=usersandbox
- if has usersandbox ${FEATURES}; then
- ewarn "You are emerging ${P} with 'usersandbox' enabled." \
- "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ if has usersandbox ${FEATURES} || ! has userpriv ${FEATURES}; then
+ ewarn "oom-score-adj related tests will be skipped." \
+ "They are known to fail with FEATURES usersandbox or -userpriv. See bug #756382."
+
+ runtestargs+=(
+ # unit/oom-score-adj was introduced in version 6.2.0
+ --skipunit unit/oom-score-adj # see bug #756382
+
+ # Following test was added in version 7.0.0 to unit/introspection.
+ # It also tries to adjust OOM score.
+ --skiptest "CONFIG SET rollback on apply error"
+ )
fi
if use ssl; then
diff --git a/dev-db/redis/redis-7.0.0.ebuild b/dev-db/redis/redis-7.0.0.ebuild
index 8fc30b963227..617c6726205d 100644
--- a/dev-db/redis/redis-7.0.0.ebuild
+++ b/dev-db/redis/redis-7.0.0.ebuild
@@ -136,10 +136,18 @@ src_test() {
--clients "$(makeopts_jobs)" # see bug #649868
)
- # Known to fail with FEATURES=usersandbox
- if has usersandbox ${FEATURES}; then
- ewarn "You are emerging ${P} with 'usersandbox' enabled." \
- "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ if has usersandbox ${FEATURES} || ! has userpriv ${FEATURES}; then
+ ewarn "oom-score-adj related tests will be skipped." \
+ "They are known to fail with FEATURES usersandbox or -userpriv. See bug #756382."
+
+ runtestargs+=(
+ # unit/oom-score-adj was introduced in version 6.2.0
+ --skipunit unit/oom-score-adj # see bug #756382
+
+ # Following test was added in version 7.0.0 to unit/introspection.
+ # It also tries to adjust OOM score.
+ --skiptest "CONFIG SET rollback on apply error"
+ )
fi
if use ssl; then
diff --git a/dev-db/redis/redis-7.0.1.ebuild b/dev-db/redis/redis-7.0.1.ebuild
index 0de72a51722e..180394de9ee9 100644
--- a/dev-db/redis/redis-7.0.1.ebuild
+++ b/dev-db/redis/redis-7.0.1.ebuild
@@ -117,10 +117,18 @@ src_test() {
--clients "$(makeopts_jobs)" # see bug #649868
)
- # Known to fail with FEATURES=usersandbox
- if has usersandbox ${FEATURES}; then
- ewarn "You are emerging ${P} with 'usersandbox' enabled." \
- "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ if has usersandbox ${FEATURES} || ! has userpriv ${FEATURES}; then
+ ewarn "oom-score-adj related tests will be skipped." \
+ "They are known to fail with FEATURES usersandbox or -userpriv. See bug #756382."
+
+ runtestargs+=(
+ # unit/oom-score-adj was introduced in version 6.2.0
+ --skipunit unit/oom-score-adj # see bug #756382
+
+ # Following test was added in version 7.0.0 to unit/introspection.
+ # It also tries to adjust OOM score.
+ --skiptest "CONFIG SET rollback on apply error"
+ )
fi
if use ssl; then