summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/redis/redis-6.2.7-r1.ebuild')
-rw-r--r--dev-db/redis/redis-6.2.7-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-db/redis/redis-6.2.7-r1.ebuild b/dev-db/redis/redis-6.2.7-r1.ebuild
index 7c3fb2239fa5..a15818f6a3db 100644
--- a/dev-db/redis/redis-6.2.7-r1.ebuild
+++ b/dev-db/redis/redis-6.2.7-r1.ebuild
@@ -136,10 +136,12 @@ src_test() {
--clients "$(makeopts_jobs)" # see bug #649868
)
- # Known to fail with FEATURES=usersandbox
- if has usersandbox ${FEATURES}; then
- ewarn "You are emerging ${P} with 'usersandbox' enabled." \
- "Expect some test failures or emerge with 'FEATURES=-usersandbox'!"
+ if has usersandbox ${FEATURES} || ! has userpriv ${FEATURES}; then
+ ewarn "unit/oom-score-adj test will be skipped." \
+ "It is known to fail with FEATURES usersandbox or -userpriv. See bug #756382."
+
+ # unit/oom-score-adj was introduced in version 6.2.0
+ runtestargs+=( --skipunit unit/oom-score-adj ) # see bug #756382
fi
if use ssl; then