summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-16 01:09:28 +0100
committerSam James <sam@gentoo.org>2022-08-16 01:10:43 +0100
commit7ed0e40edb8ce9b75521efca7fc14e71e3ac431a (patch)
treef96c18475b187c7a55a70176214288aa5473879f /sys-process/audit
parentdev-games/godot: add 4.0_alpha14 (slot:4), unkeyworded (diff)
downloadgentoo-7ed0e40edb8ce9b75521efca7fc14e71e3ac431a.tar.gz
gentoo-7ed0e40edb8ce9b75521efca7fc14e71e3ac431a.tar.bz2
gentoo-7ed0e40edb8ce9b75521efca7fc14e71e3ac431a.zip
sys-process/audit: fix musl build
Closes: https://bugs.gentoo.org/837275 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/audit')
-rw-r--r--sys-process/audit/audit-3.0.8.ebuild3
-rw-r--r--sys-process/audit/files/audit-3.0.8-musl-malloc.patch28
2 files changed, 30 insertions, 1 deletions
diff --git a/sys-process/audit/audit-3.0.8.ebuild b/sys-process/audit/audit-3.0.8.ebuild
index 4c4bfe08a040..44a6d4ffd6c5 100644
--- a/sys-process/audit/audit-3.0.8.ebuild
+++ b/sys-process/audit/audit-3.0.8.ebuild
@@ -38,6 +38,7 @@ PATCHES=(
# See bug #836702 before removing / verify builds fine w/ USE=python
# with latest kernel headers.
"${FILESDIR}"/${PN}-3.0.8-linux-headers-5.17.patch
+ "${FILESDIR}"/${PN}-3.0.8-musl-malloc.patch
)
src_prepare() {
@@ -72,7 +73,7 @@ multilib_src_configure() {
mkdir -p "${BUILD_DIR}" || die
pushd "${BUILD_DIR}" &>/dev/null || die
- ECONF_SOURCE=${S} econf "${myeconfargs[@]}" --with-python3
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}" --with-python3
popd &>/dev/null || die
}
diff --git a/sys-process/audit/files/audit-3.0.8-musl-malloc.patch b/sys-process/audit/files/audit-3.0.8-musl-malloc.patch
new file mode 100644
index 000000000000..17814dbe29fc
--- /dev/null
+++ b/sys-process/audit/files/audit-3.0.8-musl-malloc.patch
@@ -0,0 +1,28 @@
+https://cgit.openembedded.org/meta-openembedded/tree/meta-oe/recipes-security/audit/audit/0001-Replace-__attribute_malloc__-with-__attribute__-__ma.patch?id=ad978133a1a10d609bb2545882a2f720a2572f3d
+https://bugs.gentoo.org/837275
+
+From 79c8d6a2755c9dfa00a5e86378e89a94eef0504d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 9 Aug 2022 23:57:03 -0700
+Subject: [PATCH] Replace __attribute_malloc__ with
+ __attribute__((__malloc__))
+
+__attribute_malloc__ is not available on musl
+
+Fixes
+| ../../git/auparse/auparse.h:54:2: error: expected function body after function declarator
+| __attribute_malloc__ __attr_dealloc (auparse_destroy, 1);
+| ^
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/auparse/auparse.h
++++ b/auparse/auparse.h
+@@ -51,7 +51,7 @@ typedef void (*auparse_callback_ptr)(auparse_state_t *au,
+ void auparse_destroy(auparse_state_t *au);
+ void auparse_destroy_ext(auparse_state_t *au, auparse_destroy_what_t what);
+ auparse_state_t *auparse_init(ausource_t source, const void *b)
+- __attribute_malloc__ __attr_dealloc (auparse_destroy, 1);
++ __attribute__((__malloc__)) __attr_dealloc (auparse_destroy, 1);
+ int auparse_new_buffer(auparse_state_t *au, const char *data, size_t data_len)
+ __attr_access ((__read_only__, 2, 3));
+ int auparse_feed(auparse_state_t *au, const char *data, size_t data_len)