summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-03-21 11:41:08 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-03-21 11:41:08 +0100
commit7c7f6b4235d25400f6d8c409d3d0ebd56b521ff9 (patch)
tree6f57e96e3a1fb0c9483c946c368b9cabb625d94d /sci-calculators
parentdev-ml/curses: add to the tree (diff)
downloadgentoo-7c7f6b4235d25400f6d8c409d3d0ebd56b521ff9.tar.gz
gentoo-7c7f6b4235d25400f6d8c409d3d0ebd56b521ff9.tar.bz2
gentoo-7c7f6b4235d25400f6d8c409d3d0ebd56b521ff9.zip
sci-calculators/orpie: 1.6.1 bump
Bugs: https://bugs.gentoo.org/677660 Bugs: https://bugs.gentoo.org/716602 Bugs: https://bugs.gentoo.org/832679 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/orpie/Manifest1
-rw-r--r--sci-calculators/orpie/files/orpie-1.6.1-orpierc.patch11
-rw-r--r--sci-calculators/orpie/files/orpie-1.6.1-rcfile.patch14
-rw-r--r--sci-calculators/orpie/metadata.xml4
-rw-r--r--sci-calculators/orpie/orpie-1.6.1.ebuild32
5 files changed, 62 insertions, 0 deletions
diff --git a/sci-calculators/orpie/Manifest b/sci-calculators/orpie/Manifest
index 095995b428a5..c0a31cd341e2 100644
--- a/sci-calculators/orpie/Manifest
+++ b/sci-calculators/orpie/Manifest
@@ -1 +1,2 @@
DIST orpie-1.5.2.tar.gz 379583 BLAKE2B c27eedd0d065d31ea49b542e9edf3936b5f38dd83d579a3a951c89d35509774461761238492753a3ec4098a46c87568f992004b79c7f2745ea50427618984d4b SHA512 5deed6d8e8e68ce5286f4d5183315b585adef38f205805ff6ccbbbf3983c97a468e370d0d44ebe2dff596de0ad9dba20401dbc0e4e9bc176bc93b118fd1cc11a
+DIST release-1.6.1.tar.gz 277420 BLAKE2B 9b29155a62d183ea83e6bddcae62440063bb0befeff72be28be6e0e76444c830047d81c3b8eab090c8eacc81c777b347c06b01af4b5337538d046f90dadf4a23 SHA512 df998e96cef53ef595178dfb9b51a17d5b22a8ccd894a543fa3130e5ab2204ea367706a79b1f53307f97c22ec7ce866be2097a4588ffeb0479d804f56706f248
diff --git a/sci-calculators/orpie/files/orpie-1.6.1-orpierc.patch b/sci-calculators/orpie/files/orpie-1.6.1-orpierc.patch
new file mode 100644
index 000000000000..6679d645e86d
--- /dev/null
+++ b/sci-calculators/orpie/files/orpie-1.6.1-orpierc.patch
@@ -0,0 +1,11 @@
+--- a/etc/orpierc
++++ b/etc/orpierc
+@@ -4,7 +4,7 @@
+ # directory for storing Orpie data
+ set datadir="~/.orpie/"
+ # editor used for fullscreen viewing of stack elements
+-set editor="vi"
++set editor="${EDITOR}"
+ # whether or not to hide the help panel
+ set hide_help="false"
+ # whether or not to conserve memory in favor of faster rendering
diff --git a/sci-calculators/orpie/files/orpie-1.6.1-rcfile.patch b/sci-calculators/orpie/files/orpie-1.6.1-rcfile.patch
new file mode 100644
index 000000000000..19e861fd078e
--- /dev/null
+++ b/sci-calculators/orpie/files/orpie-1.6.1-rcfile.patch
@@ -0,0 +1,14 @@
+--- a/src/orpie/rcfile.ml 2022-03-21 11:25:42.405186025 +0100
++++ b/src/orpie/rcfile.ml 2022-03-21 11:24:44.477121172 +0100
+@@ -916,10 +916,7 @@
+ let rcfile_fullpath =
+ (* expand out any occurrences of ${prefix} that autoconf
+ * decides to insert *)
+- let prefix_regex = Str.regexp "\\${prefix}" in
+- let expanded_sysconfdir = Str.global_replace prefix_regex
+- Install.prefix Install.sysconfdir in
+- Utility.join_path expanded_sysconfdir "orpierc"
++ "/etc/orpie/orpierc"
+ in
+ begin try (open_in home_rcfile, home_rcfile)
+ with Sys_error error_str ->
diff --git a/sci-calculators/orpie/metadata.xml b/sci-calculators/orpie/metadata.xml
index dfde1a89b577..722736cfa60d 100644
--- a/sci-calculators/orpie/metadata.xml
+++ b/sci-calculators/orpie/metadata.xml
@@ -5,6 +5,10 @@
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
<longdescription lang="en">
Orpie is a fullscreen RPN calculator for the console. Its operation is
similar to that of modern HP calculators, but data entry has been
diff --git a/sci-calculators/orpie/orpie-1.6.1.ebuild b/sci-calculators/orpie/orpie-1.6.1.ebuild
new file mode 100644
index 000000000000..4f85a71de71b
--- /dev/null
+++ b/sci-calculators/orpie/orpie-1.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="A fullscreen RPN calculator for the console"
+HOMEPAGE="http://pessimization.com/software/orpie/"
+SRC_URI="https://github.com/pelzlpj/${PN}/archive/release-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="dev-ml/gsl-ocaml:=
+ dev-ml/curses:=
+ dev-ml/camlp5":=
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-release-${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-orpierc.patch
+ "${FILESDIR}"/${P}-rcfile.patch
+)
+
+src_install() {
+ dune_src_install
+ mv "${D}"/{/usr,}/etc || die
+}