summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/orpie/orpie-1.6.1.ebuild')
-rw-r--r--sci-calculators/orpie/orpie-1.6.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-calculators/orpie/orpie-1.6.1.ebuild b/sci-calculators/orpie/orpie-1.6.1.ebuild
new file mode 100644
index 000000000000..4f85a71de71b
--- /dev/null
+++ b/sci-calculators/orpie/orpie-1.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="A fullscreen RPN calculator for the console"
+HOMEPAGE="http://pessimization.com/software/orpie/"
+SRC_URI="https://github.com/pelzlpj/${PN}/archive/release-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="dev-ml/gsl-ocaml:=
+ dev-ml/curses:=
+ dev-ml/camlp5":=
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-release-${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-orpierc.patch
+ "${FILESDIR}"/${P}-rcfile.patch
+)
+
+src_install() {
+ dune_src_install
+ mv "${D}"/{/usr,}/etc || die
+}