summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro@users.noreply.github.com>2023-10-03 15:22:43 -0400
committerSam James <sam@gentoo.org>2023-10-03 20:30:01 +0100
commite343599977ed4c8c94626fcd8bf8496d98fef61e (patch)
tree1035f2faa9d4e3dfcc36d1a67766ff9bef324134 /dev-lang/rust/rust-1.71.0.ebuild
parentapp-accessibility/sphinx2: drop 0.6 (diff)
downloadgentoo-e343599977ed4c8c94626fcd8bf8496d98fef61e.tar.gz
gentoo-e343599977ed4c8c94626fcd8bf8496d98fef61e.tar.bz2
gentoo-e343599977ed4c8c94626fcd8bf8496d98fef61e.zip
dev-lang/rust: increase build verbosity
rust bootstrap has a lot of mysterious environment variables that need to be set in order to rerun a failing compile command manually such as RUSTC_STAGE, RUSTC_SYSROOT, RUSTC_REAL, etc. While the commands are printed at -vv verbosity level, the necessary environment variables are not, only at -vvv verbosity level. Signed-off-by: Matoro Mahri <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/rust/rust-1.71.0.ebuild')
-rw-r--r--dev-lang/rust/rust-1.71.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-lang/rust/rust-1.71.0.ebuild b/dev-lang/rust/rust-1.71.0.ebuild
index 0add3729bd1a..e73753b5c3d9 100644
--- a/dev-lang/rust/rust-1.71.0.ebuild
+++ b/dev-lang/rust/rust-1.71.0.ebuild
@@ -574,7 +574,7 @@ src_configure() {
}
src_compile() {
- RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
+ RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vvv --config="${S}"/config.toml -j$(makeopts_jobs) || die
}
src_test() {