summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro@users.noreply.github.com>2023-10-03 15:22:43 -0400
committerSam James <sam@gentoo.org>2023-10-03 20:30:01 +0100
commite343599977ed4c8c94626fcd8bf8496d98fef61e (patch)
tree1035f2faa9d4e3dfcc36d1a67766ff9bef324134
parentapp-accessibility/sphinx2: drop 0.6 (diff)
downloadgentoo-e343599977ed4c8c94626fcd8bf8496d98fef61e.tar.gz
gentoo-e343599977ed4c8c94626fcd8bf8496d98fef61e.tar.bz2
gentoo-e343599977ed4c8c94626fcd8bf8496d98fef61e.zip
dev-lang/rust: increase build verbosity
rust bootstrap has a lot of mysterious environment variables that need to be set in order to rerun a failing compile command manually such as RUSTC_STAGE, RUSTC_SYSROOT, RUSTC_REAL, etc. While the commands are printed at -vv verbosity level, the necessary environment variables are not, only at -vvv verbosity level. Signed-off-by: Matoro Mahri <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-lang/rust/rust-1.65.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.66.1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.67.1-r1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.68.2.ebuild2
-rw-r--r--dev-lang/rust/rust-1.69.0-r1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.70.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.71.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.71.1.ebuild2
-rw-r--r--dev-lang/rust/rust-1.72.0-r1.ebuild2
9 files changed, 9 insertions, 9 deletions
diff --git a/dev-lang/rust/rust-1.65.0.ebuild b/dev-lang/rust/rust-1.65.0.ebuild
index 2d8b9c47d533..db1538e1f6d8 100644
--- a/dev-lang/rust/rust-1.65.0.ebuild
+++ b/dev-lang/rust/rust-1.65.0.ebuild
@@ -580,7 +580,7 @@ src_configure() {
}
src_compile() {
- RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
+ RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vvv --config="${S}"/config.toml -j$(makeopts_jobs) || die
}
src_test() {
diff --git a/dev-lang/rust/rust-1.66.1.ebuild b/dev-lang/rust/rust-1.66.1.ebuild
index 970a5f8f50cc..57917de3e33e 100644
--- a/dev-lang/rust/rust-1.66.1.ebuild
+++ b/dev-lang/rust/rust-1.66.1.ebuild
@@ -578,7 +578,7 @@ src_configure() {
}
src_compile() {
- RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
+ RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vvv --config="${S}"/config.toml -j$(makeopts_jobs) || die
}
src_test() {
diff --git a/dev-lang/rust/rust-1.67.1-r1.ebuild b/dev-lang/rust/rust-1.67.1-r1.ebuild
index 4231d2809591..5cc9e83d5812 100644
--- a/dev-lang/rust/rust-1.67.1-r1.ebuild
+++ b/dev-lang/rust/rust-1.67.1-r1.ebuild
@@ -569,7 +569,7 @@ src_configure() {
}
src_compile() {
- RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
+ RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vvv --config="${S}"/config.toml -j$(makeopts_jobs) || die
}
src_test() {
diff --git a/dev-lang/rust/rust-1.68.2.ebuild b/dev-lang/rust/rust-1.68.2.ebuild
index 690e3ab4544e..5415b1609aae 100644
--- a/dev-lang/rust/rust-1.68.2.ebuild
+++ b/dev-lang/rust/rust-1.68.2.ebuild
@@ -568,7 +568,7 @@ src_configure() {
}
src_compile() {
- RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
+ RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vvv --config="${S}"/config.toml -j$(makeopts_jobs) || die
}
src_test() {
diff --git a/dev-lang/rust/rust-1.69.0-r1.ebuild b/dev-lang/rust/rust-1.69.0-r1.ebuild
index c5317e09dc40..f8f45a206056 100644
--- a/dev-lang/rust/rust-1.69.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.69.0-r1.ebuild
@@ -569,7 +569,7 @@ src_configure() {
}
src_compile() {
- RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
+ RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vvv --config="${S}"/config.toml -j$(makeopts_jobs) || die
}
src_test() {
diff --git a/dev-lang/rust/rust-1.70.0.ebuild b/dev-lang/rust/rust-1.70.0.ebuild
index 6a3217a13741..d3fbb420f681 100644
--- a/dev-lang/rust/rust-1.70.0.ebuild
+++ b/dev-lang/rust/rust-1.70.0.ebuild
@@ -572,7 +572,7 @@ src_configure() {
}
src_compile() {
- RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
+ RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vvv --config="${S}"/config.toml -j$(makeopts_jobs) || die
}
src_test() {
diff --git a/dev-lang/rust/rust-1.71.0.ebuild b/dev-lang/rust/rust-1.71.0.ebuild
index 0add3729bd1a..e73753b5c3d9 100644
--- a/dev-lang/rust/rust-1.71.0.ebuild
+++ b/dev-lang/rust/rust-1.71.0.ebuild
@@ -574,7 +574,7 @@ src_configure() {
}
src_compile() {
- RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
+ RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vvv --config="${S}"/config.toml -j$(makeopts_jobs) || die
}
src_test() {
diff --git a/dev-lang/rust/rust-1.71.1.ebuild b/dev-lang/rust/rust-1.71.1.ebuild
index 674ebecd31a8..f98cd61f2906 100644
--- a/dev-lang/rust/rust-1.71.1.ebuild
+++ b/dev-lang/rust/rust-1.71.1.ebuild
@@ -573,7 +573,7 @@ src_configure() {
}
src_compile() {
- RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
+ RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vvv --config="${S}"/config.toml -j$(makeopts_jobs) || die
}
src_test() {
diff --git a/dev-lang/rust/rust-1.72.0-r1.ebuild b/dev-lang/rust/rust-1.72.0-r1.ebuild
index 1ccf075cab7b..d65336b5b8a2 100644
--- a/dev-lang/rust/rust-1.72.0-r1.ebuild
+++ b/dev-lang/rust/rust-1.72.0-r1.ebuild
@@ -585,7 +585,7 @@ src_configure() {
}
src_compile() {
- RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vv --config="${S}"/config.toml -j$(makeopts_jobs) || die
+ RUST_BACKTRACE=1 "${EPYTHON}" ./x.py build -vvv --config="${S}"/config.toml -j$(makeopts_jobs) || die
}
src_test() {