summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-09-24 22:20:09 -0400
committerMatt Turner <mattst88@gentoo.org>2024-09-24 22:32:31 -0400
commit367a333f8f911be67f8f4e42d51648e387fd3459 (patch)
tree430f79120daae8564fe011ead2e17c882a4ddce8
parentdev-qt/qtwebengine: fix build with USE=-vaapi in 6.8+ (diff)
downloadgentoo-367a333f8f911be67f8f4e42d51648e387fd3459.tar.gz
gentoo-367a333f8f911be67f8f4e42d51648e387fd3459.tar.bz2
gentoo-367a333f8f911be67f8f4e42d51648e387fd3459.zip
x11-apps/xisxwayland: Use xorg-3.eclass
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-apps/xisxwayland/xisxwayland-2.ebuild25
-rw-r--r--x11-apps/xisxwayland/xisxwayland-9999.ebuild27
2 files changed, 21 insertions, 31 deletions
diff --git a/x11-apps/xisxwayland/xisxwayland-2.ebuild b/x11-apps/xisxwayland/xisxwayland-2.ebuild
index c82f6bbc37cd..ea94facec6af 100644
--- a/x11-apps/xisxwayland/xisxwayland-2.ebuild
+++ b/x11-apps/xisxwayland/xisxwayland-2.ebuild
@@ -1,29 +1,24 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+XORG_TARBALL_SUFFIX="xz"
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
- EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/app/${PN}.git"
-fi
-
-inherit ${GIT_ECLASS} meson
+inherit xorg-3 meson
-DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
-HOMEPAGE="https://gitlab.freedesktop.org/xorg/app/xisxwayland"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
-else
+if [[ ${PV} != *9999* ]]; then
KEYWORDS="amd64 ~loong"
- SRC_URI="https://xorg.freedesktop.org/archive/individual/app/${P}.tar.xz"
fi
-LICENSE="MIT"
-SLOT="0"
+DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
RDEPEND="
x11-libs/libX11
x11-libs/libXrandr"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+
+# Override xorg-3's src_prepare
+src_prepare() {
+ default
+}
diff --git a/x11-apps/xisxwayland/xisxwayland-9999.ebuild b/x11-apps/xisxwayland/xisxwayland-9999.ebuild
index c7f9d5034c09..ea94facec6af 100644
--- a/x11-apps/xisxwayland/xisxwayland-9999.ebuild
+++ b/x11-apps/xisxwayland/xisxwayland-9999.ebuild
@@ -1,29 +1,24 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+XORG_TARBALL_SUFFIX="xz"
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
- EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/app/${PN}.git"
-fi
-
-inherit ${GIT_ECLASS} meson
+inherit xorg-3 meson
-DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
-HOMEPAGE="https://gitlab.freedesktop.org/xorg/app/xisxwayland"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~amd64 ~loong"
- SRC_URI="https://xorg.freedesktop.org/archive/individual/app/${P}.tar.xz"
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="amd64 ~loong"
fi
-LICENSE="MIT"
-SLOT="0"
+DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
RDEPEND="
x11-libs/libX11
x11-libs/libXrandr"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+
+# Override xorg-3's src_prepare
+src_prepare() {
+ default
+}