summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-24 21:28:23 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-24 21:49:50 -0400
commitbbe03f19766167b539b90af2034340e61ed90e81 (patch)
tree0cbbaa0e7dc76e20d0340c5a2014ac898e65bd58
parentdev-libs/libayatana-appindicator: Stabilize 0.5.93 arm64, #935855 (diff)
downloadgentoo-bbe03f19766167b539b90af2034340e61ed90e81.tar.gz
gentoo-bbe03f19766167b539b90af2034340e61ed90e81.tar.bz2
gentoo-bbe03f19766167b539b90af2034340e61ed90e81.zip
dev-qt/qtwebengine: fix build with USE=-vaapi in 6.8+
Per the comment, already couldn't use system's libvpv when USE=vaapi is enabled (this is intentionally enforced by the build system rather than "broken"), and now USE=-vaapi fails to build in 6.8 with system's. Seems like an easy fix but (even if fixed) feel it would be simpler keep the same setup regardless of USE=vaapi until vaapi allows using system's. I hardly test USE=-vaapi and missed that it broke, and I assume this holds for upstream too. qtwebengine does keep bundled libvpx either up to date or backports security fixes, albeit bumps are less frequent and fixes could lag a bit (not that we had a choice with USE=vaapi either way, unless drop vaapi support). As a small perk, it'll spare users from rebuilding qtwebengine on libvpx subslot bumps which happen now and then. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.8.0_rc.ebuild7
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild7
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.9999.ebuild7
3 files changed, 12 insertions, 9 deletions
diff --git a/dev-qt/qtwebengine/qtwebengine-6.8.0_rc.ebuild b/dev-qt/qtwebengine/qtwebengine-6.8.0_rc.ebuild
index 040cde6137b6..6b40caa515b0 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.8.0_rc.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.8.0_rc.ebuild
@@ -77,7 +77,6 @@ RDEPEND="
)
system-icu? ( dev-libs/icu:= )
vaapi? ( media-libs/libva:=[X] )
- !vaapi? ( media-libs/libvpx:= )
"
DEPEND="
${RDEPEND}
@@ -207,8 +206,10 @@ src_configure() {
# this by default in 6.7.3+ (bug #913923)
-DQT_FEATURE_webengine_system_re2=OFF
- # bundled is currently required when using vaapi (forced regardless)
- $(qt_feature !vaapi webengine_system_libvpx)
+ # system_libvpx=ON is intentionally ignored with USE=vaapi which leads
+ # to using system's being less tested, prefer disabling for now until
+ # vaapi can use it as well
+ -DQT_FEATURE_webengine_system_libvpx=OFF
# not necessary to pass these (default), but in case detection fails
$(printf -- '-DQT_FEATURE_webengine_system_%s=ON ' \
diff --git a/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild
index 040cde6137b6..6b40caa515b0 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.8.9999.ebuild
@@ -77,7 +77,6 @@ RDEPEND="
)
system-icu? ( dev-libs/icu:= )
vaapi? ( media-libs/libva:=[X] )
- !vaapi? ( media-libs/libvpx:= )
"
DEPEND="
${RDEPEND}
@@ -207,8 +206,10 @@ src_configure() {
# this by default in 6.7.3+ (bug #913923)
-DQT_FEATURE_webengine_system_re2=OFF
- # bundled is currently required when using vaapi (forced regardless)
- $(qt_feature !vaapi webengine_system_libvpx)
+ # system_libvpx=ON is intentionally ignored with USE=vaapi which leads
+ # to using system's being less tested, prefer disabling for now until
+ # vaapi can use it as well
+ -DQT_FEATURE_webengine_system_libvpx=OFF
# not necessary to pass these (default), but in case detection fails
$(printf -- '-DQT_FEATURE_webengine_system_%s=ON ' \
diff --git a/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
index 040cde6137b6..6b40caa515b0 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
@@ -77,7 +77,6 @@ RDEPEND="
)
system-icu? ( dev-libs/icu:= )
vaapi? ( media-libs/libva:=[X] )
- !vaapi? ( media-libs/libvpx:= )
"
DEPEND="
${RDEPEND}
@@ -207,8 +206,10 @@ src_configure() {
# this by default in 6.7.3+ (bug #913923)
-DQT_FEATURE_webengine_system_re2=OFF
- # bundled is currently required when using vaapi (forced regardless)
- $(qt_feature !vaapi webengine_system_libvpx)
+ # system_libvpx=ON is intentionally ignored with USE=vaapi which leads
+ # to using system's being less tested, prefer disabling for now until
+ # vaapi can use it as well
+ -DQT_FEATURE_webengine_system_libvpx=OFF
# not necessary to pass these (default), but in case detection fails
$(printf -- '-DQT_FEATURE_webengine_system_%s=ON ' \