summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild')
-rw-r--r--dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild b/dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild
new file mode 100644
index 000000000000..ec0424a528c1
--- /dev/null
+++ b/dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild,v 1.1 2010/08/21 21:01:11 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_TASK_TEST="spec:normal"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple library to generate UUIDs"
+HOMEPAGE="http://uuidtools.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Rakefile does not work without rspec (and is quite difficult to work
+# it around).
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/rspec-1.0.8 )
+ test? ( >=dev-ruby/rspec-1.0.8 )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '1d; 2i require File.expand_path("../../spec_helper.rb", __FILE__)' \
+ "${S}"/spec/uuidtools/*.rb || die
+}