summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-21 21:01:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-08-21 21:01:11 +0000
commitf3bb620fa1a4b6fc32a4107b3568357189cd7479 (patch)
tree891062a51f12f99b9dc67c723333dc4e3a3796e4 /dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild
parentRemove unused file. Remove examples USE flag, always install them (uncompress... (diff)
downloadgentoo-2-f3bb620fa1a4b6fc32a4107b3568357189cd7479.tar.gz
gentoo-2-f3bb620fa1a4b6fc32a4107b3568357189cd7479.tar.bz2
gentoo-2-f3bb620fa1a4b6fc32a4107b3568357189cd7479.zip
Remove unused file and prepare a revision with Ruby 1.9 so a new one can be stabilized.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild')
-rw-r--r--dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild b/dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild
new file mode 100644
index 000000000000..ec0424a528c1
--- /dev/null
+++ b/dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/uuidtools/uuidtools-2.1.1-r2.ebuild,v 1.1 2010/08/21 21:01:11 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_TASK_TEST="spec:normal"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple library to generate UUIDs"
+HOMEPAGE="http://uuidtools.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Rakefile does not work without rspec (and is quite difficult to work
+# it around).
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/rspec-1.0.8 )
+ test? ( >=dev-ruby/rspec-1.0.8 )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '1d; 2i require File.expand_path("../../spec_helper.rb", __FILE__)' \
+ "${S}"/spec/uuidtools/*.rb || die
+}