summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-01-07 05:14:09 +0000
committerOlivier Crête <tester@gentoo.org>2008-01-07 05:14:09 +0000
commitedb451b2fc79f972f80d5828b03d0dd20ae16ec4 (patch)
tree7c40056b883433edf777cc8e114e286fb1d89258 /x11-plugins/guifications
parentAdd dep on gtk (and check that pidgin has it too) (diff)
downloadgentoo-2-edb451b2fc79f972f80d5828b03d0dd20ae16ec4.tar.gz
gentoo-2-edb451b2fc79f972f80d5828b03d0dd20ae16ec4.tar.bz2
gentoo-2-edb451b2fc79f972f80d5828b03d0dd20ae16ec4.zip
Add dep on gtk (and check that pidgin has it too)
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-plugins/guifications')
-rw-r--r--x11-plugins/guifications/ChangeLog6
-rw-r--r--x11-plugins/guifications/guifications-2.14.ebuild17
-rw-r--r--x11-plugins/guifications/guifications-2.16.ebuild15
3 files changed, 32 insertions, 6 deletions
diff --git a/x11-plugins/guifications/ChangeLog b/x11-plugins/guifications/ChangeLog
index 12ffaf40212f..6ae3b3f7eb7a 100644
--- a/x11-plugins/guifications/ChangeLog
+++ b/x11-plugins/guifications/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/guifications
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/ChangeLog,v 1.52 2008/01/03 19:31:44 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/ChangeLog,v 1.53 2008/01/07 05:14:09 tester Exp $
+
+ 07 Jan 2008; <tester@gentoo.org> guifications-2.14.ebuild,
+ guifications-2.16.ebuild:
+ Add dep on gtk (and check that pidgin has it too)
*guifications-2.16 (03 Jan 2008)
diff --git a/x11-plugins/guifications/guifications-2.14.ebuild b/x11-plugins/guifications/guifications-2.14.ebuild
index cea2bf039484..038e2d2eb1ac 100644
--- a/x11-plugins/guifications/guifications-2.14.ebuild
+++ b/x11-plugins/guifications/guifications-2.14.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/guifications-2.14.ebuild,v 1.7 2007/12/08 16:33:47 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/guifications-2.14.ebuild,v 1.8 2008/01/07 05:14:09 tester Exp $
MY_PN=pidgin-${PN}
MY_PV=${PV/_beta/beta}
@@ -15,7 +15,18 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc sparc x86"
IUSE="debug nls"
-DEPEND="net-im/pidgin"
+RDEPEND="net-im/pidgin
+ >=x11-libs/gtk+-2"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if ! built_with_use net-im/pidgin gtk; then
+ eerror "You need to compile net-im/pidgin with USE=gtk"
+ die "Missing gtk USE flag on net-im/pidgin"
+ fi
+}
src_compile() {
econf \
diff --git a/x11-plugins/guifications/guifications-2.16.ebuild b/x11-plugins/guifications/guifications-2.16.ebuild
index ee9d551e1522..38313f185a34 100644
--- a/x11-plugins/guifications/guifications-2.16.ebuild
+++ b/x11-plugins/guifications/guifications-2.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/guifications-2.16.ebuild,v 1.1 2008/01/03 19:31:44 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/guifications-2.16.ebuild,v 1.2 2008/01/07 05:14:09 tester Exp $
MY_PN=pidgin-${PN}
MY_PV=${PV/_beta/beta}
@@ -15,7 +15,18 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
IUSE="debug nls"
-DEPEND="net-im/pidgin"
+RDEPEND="net-im/pidgin
+ >=x11-libs/gtk+-2"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if ! built_with_use net-im/pidgin gtk; then
+ eerror "You need to compile net-im/pidgin with USE=gtk"
+ die "Missing gtk USE flag on net-im/pidgin"
+ fi
+}
src_compile() {
econf \