summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/guifications/guifications-2.16.ebuild')
-rw-r--r--x11-plugins/guifications/guifications-2.16.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/x11-plugins/guifications/guifications-2.16.ebuild b/x11-plugins/guifications/guifications-2.16.ebuild
index ee9d551e1522..38313f185a34 100644
--- a/x11-plugins/guifications/guifications-2.16.ebuild
+++ b/x11-plugins/guifications/guifications-2.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/guifications-2.16.ebuild,v 1.1 2008/01/03 19:31:44 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/guifications/guifications-2.16.ebuild,v 1.2 2008/01/07 05:14:09 tester Exp $
MY_PN=pidgin-${PN}
MY_PV=${PV/_beta/beta}
@@ -15,7 +15,18 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
IUSE="debug nls"
-DEPEND="net-im/pidgin"
+RDEPEND="net-im/pidgin
+ >=x11-libs/gtk+-2"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ if ! built_with_use net-im/pidgin gtk; then
+ eerror "You need to compile net-im/pidgin with USE=gtk"
+ die "Missing gtk USE flag on net-im/pidgin"
+ fi
+}
src_compile() {
econf \