summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-12-29 13:49:20 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-12-29 13:49:20 +0000
commitaa323c40a4dc51b0b1dafe263730d5a578a327e6 (patch)
treec6a4993d50eaee58bad0fc2b844787666f4c192f /x11-libs/qt-svg/qt-svg-4.8.2.ebuild
parentRemove old. (diff)
downloadgentoo-2-aa323c40a4dc51b0b1dafe263730d5a578a327e6.tar.gz
gentoo-2-aa323c40a4dc51b0b1dafe263730d5a578a327e6.tar.bz2
gentoo-2-aa323c40a4dc51b0b1dafe263730d5a578a327e6.zip
Remove old.
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'x11-libs/qt-svg/qt-svg-4.8.2.ebuild')
-rw-r--r--x11-libs/qt-svg/qt-svg-4.8.2.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/x11-libs/qt-svg/qt-svg-4.8.2.ebuild b/x11-libs/qt-svg/qt-svg-4.8.2.ebuild
deleted file mode 100644
index 77aecf6f7893..000000000000
--- a/x11-libs/qt-svg/qt-svg-4.8.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.8.2.ebuild,v 1.10 2012/10/14 17:21:19 armin76 Exp $
-
-EAPI=4
-
-inherit qt4-build
-
-DESCRIPTION="The SVG module for the Qt toolkit"
-SLOT="4"
-if [[ ${QT4_BUILD_TYPE} == live ]]; then
- KEYWORDS=""
-else
- KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-fi
-IUSE="+accessibility"
-
-DEPEND="
- sys-libs/zlib
- ~x11-libs/qt-core-${PV}[aqua=,c++0x=,debug=,qpa=]
- ~x11-libs/qt-gui-${PV}[accessibility=,aqua=,c++0x=,debug=,qpa=]
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PV}-qatomic-x32.patch"
-)
-
-pkg_setup() {
- QT4_TARGET_DIRECTORIES="
- src/svg
- src/plugins/imageformats/svg
- src/plugins/iconengines/svgiconengine"
-
- QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
- include/QtSvg
- include/Qt
- include/QtGui
- include/QtCore
- include/QtXml
- src/corelib
- src/gui
- src/plugins
- src/xml
- src/3rdparty"
-
- QCONFIG_ADD="svg"
- QCONFIG_DEFINE="QT_SVG"
-
- qt4-build_pkg_setup
-}
-
-src_configure() {
- myconf+="
- -svg
- $(qt_use accessibility)
- -no-xkb -no-xrender
- -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
- -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
- -no-fontconfig -no-glib -no-gtkstyle"
-
- qt4-build_src_configure
-}