summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/qt-svg/ChangeLog7
-rw-r--r--x11-libs/qt-svg/files/4.8.2-qatomic-x32.patch50
-rw-r--r--x11-libs/qt-svg/qt-svg-4.7.4.ebuild50
-rw-r--r--x11-libs/qt-svg/qt-svg-4.8.1.ebuild57
-rw-r--r--x11-libs/qt-svg/qt-svg-4.8.2.ebuild65
-rw-r--r--x11-libs/qt-svg/qt-svg-4.8.3.ebuild61
6 files changed, 6 insertions, 284 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index e0df3fc86be8..cbd4bbe8cd59 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.134 2012/12/29 08:48:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.135 2012/12/29 13:49:19 kensington Exp $
+
+ 29 Dec 2012; Michael Palimaka <kensington@gentoo.org>
+ -files/4.8.2-qatomic-x32.patch, -qt-svg-4.7.4.ebuild, -qt-svg-4.8.1.ebuild,
+ -qt-svg-4.8.2.ebuild, -qt-svg-4.8.3.ebuild:
+ Remove old.
29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> qt-svg-4.8.4.ebuild:
Stable for alpha, wrt bug #445956
diff --git a/x11-libs/qt-svg/files/4.8.2-qatomic-x32.patch b/x11-libs/qt-svg/files/4.8.2-qatomic-x32.patch
deleted file mode 100644
index 5f352b1acc83..000000000000
--- a/x11-libs/qt-svg/files/4.8.2-qatomic-x32.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 29384815fb74ddfa90007f9ffede77be45e9a0fd Mon Sep 17 00:00:00 2001
-From: Davide Pesavento <davidepesa@gmail.com>
-Date: Thu, 14 Jun 2012 00:44:43 +0200
-Subject: [PATCH] Fix qatomic inline asm for x32 ABI.
-
-Drop the 'q' suffix from x86_64 asm instructions. It's not needed,
-because the assembler can automatically determine the proper size
-based on the target, and it is in fact causing compilation failures
-on x32.
-
-Change-Id: Ie6ff3ddf352a63bc490acce97a3019ce2e48dc70
-Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
----
- src/corelib/arch/qatomic_x86_64.h | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/corelib/arch/qatomic_x86_64.h b/src/corelib/arch/qatomic_x86_64.h
-index c2627c8..dc78140 100644
---- a/src/corelib/arch/qatomic_x86_64.h
-+++ b/src/corelib/arch/qatomic_x86_64.h
-@@ -170,7 +170,7 @@ Q_INLINE_TEMPLATE bool QBasicAtomicPointer<T>::testAndSetOrdered(T *expectedValu
- {
- unsigned char ret;
- asm volatile("lock\n"
-- "cmpxchgq %3,%2\n"
-+ "cmpxchg %3,%2\n"
- "sete %1\n"
- : "=a" (newValue), "=qm" (ret), "+m" (_q_value)
- : "r" (newValue), "0" (expectedValue)
-@@ -181,7 +181,7 @@ Q_INLINE_TEMPLATE bool QBasicAtomicPointer<T>::testAndSetOrdered(T *expectedValu
- template <typename T>
- Q_INLINE_TEMPLATE T *QBasicAtomicPointer<T>::fetchAndStoreOrdered(T *newValue)
- {
-- asm volatile("xchgq %0,%1"
-+ asm volatile("xchg %0,%1"
- : "=r" (newValue), "+m" (_q_value)
- : "0" (newValue)
- : "memory");
-@@ -192,7 +192,7 @@ template <typename T>
- Q_INLINE_TEMPLATE T *QBasicAtomicPointer<T>::fetchAndAddOrdered(qptrdiff valueToAdd)
- {
- asm volatile("lock\n"
-- "xaddq %0,%1"
-+ "xadd %0,%1"
- : "=r" (valueToAdd), "+m" (_q_value)
- : "0" (valueToAdd * sizeof(T))
- : "memory");
---
-1.7.10
-
diff --git a/x11-libs/qt-svg/qt-svg-4.7.4.ebuild b/x11-libs/qt-svg/qt-svg-4.7.4.ebuild
deleted file mode 100644
index 9b42ecb05308..000000000000
--- a/x11-libs/qt-svg/qt-svg-4.7.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.7.4.ebuild,v 1.5 2012/04/03 21:50:33 jer Exp $
-
-EAPI="3"
-inherit qt4-build
-
-DESCRIPTION="The SVG module for the Qt toolkit"
-SLOT="4"
-KEYWORDS="amd64 ~arm hppa ~ia64 ~mips ppc ppc64 -sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="+accessibility iconv"
-
-DEPEND="~x11-libs/qt-gui-${PV}[accessibility=,aqua=,debug=]"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- QT4_TARGET_DIRECTORIES="
- src/svg
- src/plugins/imageformats/svg
- src/plugins/iconengines/svgiconengine"
- QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
- include/QtSvg/
- include/Qt/
- include/QtGui/
- include/QtCore/
- include/QtXml/
- src/corelib/
- src/gui/
- src/plugins/
- src/xml
- src/3rdparty"
-
- QCONFIG_ADD="svg"
- QCONFIG_DEFINE="QT_SVG"
-
- qt4-build_pkg_setup
-}
-
-src_configure() {
- myconf="${myconf} -svg
- $(qt_use iconv)
- $(qt_use accessibility)
- -no-xkb -no-xrender
- -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
- -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
- -no-fontconfig -no-glib -no-gtkstyle"
- qt4-build_src_configure
-}
diff --git a/x11-libs/qt-svg/qt-svg-4.8.1.ebuild b/x11-libs/qt-svg/qt-svg-4.8.1.ebuild
deleted file mode 100644
index 2a995cf13850..000000000000
--- a/x11-libs/qt-svg/qt-svg-4.8.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.8.1.ebuild,v 1.9 2012/07/08 18:02:21 armin76 Exp $
-
-EAPI=4
-
-inherit qt4-build
-
-DESCRIPTION="The SVG module for the Qt toolkit"
-SLOT="4"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="+accessibility"
-
-DEPEND="
- sys-libs/zlib
- ~x11-libs/qt-core-${PV}[aqua=,c++0x=,debug=,qpa=]
- ~x11-libs/qt-gui-${PV}[accessibility=,aqua=,c++0x=,debug=,qpa=]
-"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- QT4_TARGET_DIRECTORIES="
- src/svg
- src/plugins/imageformats/svg
- src/plugins/iconengines/svgiconengine"
-
- QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
- include/QtSvg
- include/Qt
- include/QtGui
- include/QtCore
- include/QtXml
- src/corelib
- src/gui
- src/plugins
- src/xml
- src/3rdparty"
-
- QCONFIG_ADD="svg"
- QCONFIG_DEFINE="QT_SVG"
-
- qt4-build_pkg_setup
-}
-
-src_configure() {
- myconf+="
- -svg
- $(qt_use accessibility)
- -no-xkb -no-xrender
- -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
- -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
- -no-fontconfig -no-glib -no-gtkstyle"
-
- qt4-build_src_configure
-}
diff --git a/x11-libs/qt-svg/qt-svg-4.8.2.ebuild b/x11-libs/qt-svg/qt-svg-4.8.2.ebuild
deleted file mode 100644
index 77aecf6f7893..000000000000
--- a/x11-libs/qt-svg/qt-svg-4.8.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.8.2.ebuild,v 1.10 2012/10/14 17:21:19 armin76 Exp $
-
-EAPI=4
-
-inherit qt4-build
-
-DESCRIPTION="The SVG module for the Qt toolkit"
-SLOT="4"
-if [[ ${QT4_BUILD_TYPE} == live ]]; then
- KEYWORDS=""
-else
- KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-fi
-IUSE="+accessibility"
-
-DEPEND="
- sys-libs/zlib
- ~x11-libs/qt-core-${PV}[aqua=,c++0x=,debug=,qpa=]
- ~x11-libs/qt-gui-${PV}[accessibility=,aqua=,c++0x=,debug=,qpa=]
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PV}-qatomic-x32.patch"
-)
-
-pkg_setup() {
- QT4_TARGET_DIRECTORIES="
- src/svg
- src/plugins/imageformats/svg
- src/plugins/iconengines/svgiconengine"
-
- QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
- include/QtSvg
- include/Qt
- include/QtGui
- include/QtCore
- include/QtXml
- src/corelib
- src/gui
- src/plugins
- src/xml
- src/3rdparty"
-
- QCONFIG_ADD="svg"
- QCONFIG_DEFINE="QT_SVG"
-
- qt4-build_pkg_setup
-}
-
-src_configure() {
- myconf+="
- -svg
- $(qt_use accessibility)
- -no-xkb -no-xrender
- -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
- -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
- -no-fontconfig -no-glib -no-gtkstyle"
-
- qt4-build_src_configure
-}
diff --git a/x11-libs/qt-svg/qt-svg-4.8.3.ebuild b/x11-libs/qt-svg/qt-svg-4.8.3.ebuild
deleted file mode 100644
index abbc3e3beedc..000000000000
--- a/x11-libs/qt-svg/qt-svg-4.8.3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.8.3.ebuild,v 1.2 2012/09/16 04:48:47 yngwin Exp $
-
-EAPI=4
-
-inherit qt4-build
-
-DESCRIPTION="The SVG module for the Qt toolkit"
-SLOT="4"
-if [[ ${QT4_BUILD_TYPE} == live ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-fi
-IUSE="+accessibility"
-
-DEPEND="
- sys-libs/zlib
- ~x11-libs/qt-core-${PV}[aqua=,debug=]
- ~x11-libs/qt-gui-${PV}[accessibility=,aqua=,debug=]
-"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- QT4_TARGET_DIRECTORIES="
- src/svg
- src/plugins/imageformats/svg
- src/plugins/iconengines/svgiconengine"
-
- QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
- include/QtSvg
- include/Qt
- include/QtGui
- include/QtCore
- include/QtXml
- src/corelib
- src/gui
- src/plugins
- src/xml
- src/3rdparty"
-
- QCONFIG_ADD="svg"
- QCONFIG_DEFINE="QT_SVG"
-
- qt4-build_pkg_setup
-}
-
-src_configure() {
- myconf+="
- -svg
- $(qt_use accessibility)
- -no-xkb -no-xrender
- -no-xrandr -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm
- -no-opengl -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
- -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
- -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff
- -no-fontconfig -no-glib -no-gtkstyle"
-
- qt4-build_src_configure
-}