summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-05-29 20:47:37 +0000
committerTravis Tilley <lv@gentoo.org>2004-05-29 20:47:37 +0000
commit641c6f8fe1722d8d9e8352f7d8fae50cce042bd0 (patch)
tree74eae307137c26250f41419751e31af76a27156d /sys-apps/parted
parent-ftracer + gcc-3.4.0 == broken #52269 (diff)
downloadgentoo-2-641c6f8fe1722d8d9e8352f7d8fae50cce042bd0.tar.gz
gentoo-2-641c6f8fe1722d8d9e8352f7d8fae50cce042bd0.tar.bz2
gentoo-2-641c6f8fe1722d8d9e8352f7d8fae50cce042bd0.zip
added --disable-Werror so that silly little warnings dont make parted fail to compile using gcc 3.4 and added ~amd64 keyword to parted 1.6.10-r1
Diffstat (limited to 'sys-apps/parted')
-rw-r--r--sys-apps/parted/ChangeLog8
-rw-r--r--sys-apps/parted/parted-1.6.10-r1.ebuild5
-rw-r--r--sys-apps/parted/parted-1.6.10.ebuild3
-rw-r--r--sys-apps/parted/parted-1.6.6-r1.ebuild3
-rw-r--r--sys-apps/parted/parted-1.6.6.ebuild3
-rw-r--r--sys-apps/parted/parted-1.6.8-r1.ebuild3
-rw-r--r--sys-apps/parted/parted-1.6.8.ebuild3
-rw-r--r--sys-apps/parted/parted-1.6.9.ebuild3
8 files changed, 22 insertions, 9 deletions
diff --git a/sys-apps/parted/ChangeLog b/sys-apps/parted/ChangeLog
index 1e4f1e27076e..a195c7f27c60 100644
--- a/sys-apps/parted/ChangeLog
+++ b/sys-apps/parted/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/parted
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.42 2004/05/04 04:05:26 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/ChangeLog,v 1.43 2004/05/29 20:47:37 lv Exp $
+
+ 29 May 2004; Travis Tilley <lv@gentoo.org> parted-1.6.10-r1.ebuild,
+ parted-1.6.10.ebuild, parted-1.6.6-r1.ebuild, parted-1.6.6.ebuild,
+ parted-1.6.8-r1.ebuild, parted-1.6.8.ebuild, parted-1.6.9.ebuild:
+ added --disable-Werror so that silly little warnings dont make parted fail to
+ compile using gcc 3.4 and added ~amd64 keyword to parted 1.6.10-r1
03 May 2004; Tom Gall <tgall@gentoo.org> parted-1.6.8-r1.ebuild:
stable on ppc64, slight change to get rid of -Werror on ppc64 (useless *&*(T^)
diff --git a/sys-apps/parted/parted-1.6.10-r1.ebuild b/sys-apps/parted/parted-1.6.10-r1.ebuild
index bfb287cf1f34..4ef9d9fada71 100644
--- a/sys-apps/parted/parted-1.6.10-r1.ebuild
+++ b/sys-apps/parted/parted-1.6.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.10-r1.ebuild,v 1.2 2004/04/27 21:23:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.10-r1.ebuild,v 1.3 2004/05/29 20:47:37 lv Exp $
inherit eutils
@@ -13,7 +13,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 -*"
+KEYWORDS="~x86 -* ~amd64"
IUSE="nls static readline debug noreiserfs"
DEPEND=">=sys-fs/e2fsprogs-1.27
@@ -38,6 +38,7 @@ src_compile() {
`use_enable nls` \
`use_enable debug` \
`use_enable static all-static` \
+ --disable-Werror \
--target=${CHOST} ${myconf} || die "Configure failed"
emake || die "Make failed"
}
diff --git a/sys-apps/parted/parted-1.6.10.ebuild b/sys-apps/parted/parted-1.6.10.ebuild
index 6b0fe46489b4..b73dc8f08b88 100644
--- a/sys-apps/parted/parted-1.6.10.ebuild
+++ b/sys-apps/parted/parted-1.6.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.10.ebuild,v 1.2 2004/04/27 21:23:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.10.ebuild,v 1.3 2004/05/29 20:47:37 lv Exp $
inherit eutils
@@ -38,6 +38,7 @@ src_compile() {
`use_enable nls` \
`use_enable debug` \
`use_enable static all-static` \
+ --disable-Werror \
--target=${CHOST} ${myconf} || die "Configure failed"
emake || die "Make failed"
}
diff --git a/sys-apps/parted/parted-1.6.6-r1.ebuild b/sys-apps/parted/parted-1.6.6-r1.ebuild
index fc41f9252178..7966dd5d55a7 100644
--- a/sys-apps/parted/parted-1.6.6-r1.ebuild
+++ b/sys-apps/parted/parted-1.6.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.6-r1.ebuild,v 1.6 2004/04/27 21:23:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.6-r1.ebuild,v 1.7 2004/05/29 20:47:37 lv Exp $
inherit eutils
@@ -38,6 +38,7 @@ src_compile() {
`use_enable nls` \
`use_enable debug` \
`use_enable static all-static` \
+ --disable-Werror \
--target=${CHOST} ${myconf} || die "Configure failed"
emake || die "Make failed"
}
diff --git a/sys-apps/parted/parted-1.6.6.ebuild b/sys-apps/parted/parted-1.6.6.ebuild
index a1eccc8c0a15..4647b57693c3 100644
--- a/sys-apps/parted/parted-1.6.6.ebuild
+++ b/sys-apps/parted/parted-1.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.6.ebuild,v 1.16 2004/04/27 21:23:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.6.ebuild,v 1.17 2004/05/29 20:47:37 lv Exp $
inherit gnuconfig eutils
@@ -40,6 +40,7 @@ src_compile() {
`use_enable nls` \
`use_enable debug` \
`use_enable static all-static` \
+ --disable-Werror \
--target=${CHOST} || die "Configure failed"
emake || die "Make failed"
}
diff --git a/sys-apps/parted/parted-1.6.8-r1.ebuild b/sys-apps/parted/parted-1.6.8-r1.ebuild
index a654ae59096c..135efdad31e5 100644
--- a/sys-apps/parted/parted-1.6.8-r1.ebuild
+++ b/sys-apps/parted/parted-1.6.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.8-r1.ebuild,v 1.4 2004/05/04 04:05:26 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.8-r1.ebuild,v 1.5 2004/05/29 20:47:37 lv Exp $
inherit eutils
@@ -39,6 +39,7 @@ src_compile() {
`use_enable nls` \
`use_enable debug` \
`use_enable static all-static` \
+ --disable-Werror \
--target=${CHOST} ${myconf} || die "Configure failed"
emake || die "Make failed"
}
diff --git a/sys-apps/parted/parted-1.6.8.ebuild b/sys-apps/parted/parted-1.6.8.ebuild
index 628e0f07dce8..3ef6a8330f7e 100644
--- a/sys-apps/parted/parted-1.6.8.ebuild
+++ b/sys-apps/parted/parted-1.6.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.8.ebuild,v 1.3 2004/04/27 21:23:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.8.ebuild,v 1.4 2004/05/29 20:47:37 lv Exp $
inherit eutils
@@ -38,6 +38,7 @@ src_compile() {
`use_enable nls` \
`use_enable debug` \
`use_enable static all-static` \
+ --disable-Werror \
--target=${CHOST} ${myconf} || die "Configure failed"
emake || die "Make failed"
}
diff --git a/sys-apps/parted/parted-1.6.9.ebuild b/sys-apps/parted/parted-1.6.9.ebuild
index a9f0739a316f..c61cd9be8579 100644
--- a/sys-apps/parted/parted-1.6.9.ebuild
+++ b/sys-apps/parted/parted-1.6.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.9.ebuild,v 1.2 2004/04/27 21:23:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/parted/parted-1.6.9.ebuild,v 1.3 2004/05/29 20:47:37 lv Exp $
inherit eutils
@@ -38,6 +38,7 @@ src_compile() {
`use_enable nls` \
`use_enable debug` \
`use_enable static all-static` \
+ --disable-Werror \
--target=${CHOST} ${myconf} || die "Configure failed"
emake || die "Make failed"
}