summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-02-23 02:46:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-02-23 02:46:07 +0000
commit3e6958bc0f0ffdac53c873f16b98547e0fa08ec7 (patch)
tree13f93d35d7aadbddafbf1a17280875c7c8a95e63 /sci-physics/fastjet
parentVersion bump (diff)
downloadgentoo-2-3e6958bc0f0ffdac53c873f16b98547e0fa08ec7.tar.gz
gentoo-2-3e6958bc0f0ffdac53c873f16b98547e0fa08ec7.tar.bz2
gentoo-2-3e6958bc0f0ffdac53c873f16b98547e0fa08ec7.zip
Version bump
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-physics/fastjet')
-rw-r--r--sci-physics/fastjet/ChangeLog9
-rw-r--r--sci-physics/fastjet/fastjet-3.0.6.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/sci-physics/fastjet/ChangeLog b/sci-physics/fastjet/ChangeLog
index 6abcf9e20934..13a56f09be25 100644
--- a/sci-physics/fastjet/ChangeLog
+++ b/sci-physics/fastjet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/fastjet
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.7 2013/06/04 17:35:13 bicatali Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.8 2014/02/23 02:46:07 bicatali Exp $
+
+*fastjet-3.0.6 (23 Feb 2014)
+
+ 23 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> +fastjet-3.0.6.ebuild:
+ Version bump
04 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> fastjet-3.0.3-r1.ebuild,
files/fastjet-3.0.3-system-siscone.patch, metadata.xml:
diff --git a/sci-physics/fastjet/fastjet-3.0.6.ebuild b/sci-physics/fastjet/fastjet-3.0.6.ebuild
new file mode 100644
index 000000000000..289ca8f8ec20
--- /dev/null
+++ b/sci-physics/fastjet/fastjet-3.0.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.6.ebuild,v 1.1 2014/02/23 02:46:07 bicatali Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=plugins
+
+inherit autotools-utils fortran-2 flag-o-matic
+
+DESCRIPTION="Fast implementation of several recombination jet algorithms"
+HOMEPAGE="http://www.fastjet.fr/"
+SRC_URI="${HOMEPAGE}/repo/${P}.tar.gz"
+
+LICENSE="GPL-2 QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cgal doc examples +plugins static-libs"
+
+RDEPEND="cgal? ( sci-mathematics/cgal )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ plugins? ( sci-physics/siscone )"
+
+src_configure() {
+ use cgal && has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
+ local myeconfargs=(
+ $(use_enable cgal)
+ $(use_enable plugins allplugins)
+ $(use_enable plugins allcxxplugins)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml -r html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ find example \
+ -name Makefile -or Makefile.in -or Makefile.am -delete
+ doins -r example/*
+ fi
+}