summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/fastjet/fastjet-3.0.6.ebuild')
-rw-r--r--sci-physics/fastjet/fastjet-3.0.6.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-physics/fastjet/fastjet-3.0.6.ebuild b/sci-physics/fastjet/fastjet-3.0.6.ebuild
new file mode 100644
index 000000000000..289ca8f8ec20
--- /dev/null
+++ b/sci-physics/fastjet/fastjet-3.0.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.6.ebuild,v 1.1 2014/02/23 02:46:07 bicatali Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=plugins
+
+inherit autotools-utils fortran-2 flag-o-matic
+
+DESCRIPTION="Fast implementation of several recombination jet algorithms"
+HOMEPAGE="http://www.fastjet.fr/"
+SRC_URI="${HOMEPAGE}/repo/${P}.tar.gz"
+
+LICENSE="GPL-2 QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cgal doc examples +plugins static-libs"
+
+RDEPEND="cgal? ( sci-mathematics/cgal )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ plugins? ( sci-physics/siscone )"
+
+src_configure() {
+ use cgal && has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
+ local myeconfargs=(
+ $(use_enable cgal)
+ $(use_enable plugins allplugins)
+ $(use_enable plugins allcxxplugins)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml -r html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ find example \
+ -name Makefile -or Makefile.in -or Makefile.am -delete
+ doins -r example/*
+ fi
+}