summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-12-08 22:15:02 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-12-08 22:15:02 +0000
commitbdd79cc8a50207d50336d58552e7d8af805bfbd0 (patch)
tree4a8ca5711af567e177df714230064db0df680015 /sci-chemistry/gromacs
parentFix LICENSE, GPL-2+ according to notices in source files. (diff)
downloadgentoo-2-bdd79cc8a50207d50336d58552e7d8af805bfbd0.tar.gz
gentoo-2-bdd79cc8a50207d50336d58552e7d8af805bfbd0.tar.bz2
gentoo-2-bdd79cc8a50207d50336d58552e7d8af805bfbd0.zip
CMAKE_BUILD_DIR -> BUILD_DIR
(Portage version: 2.2.0_alpha145/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/ChangeLog6
-rw-r--r--sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild14
-rw-r--r--sci-chemistry/gromacs/gromacs-4.6_beta2.ebuild20
3 files changed, 22 insertions, 18 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index 44786a8a7960..1e26308fc329 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/gromacs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.112 2012/12/07 02:52:37 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.113 2012/12/08 22:15:02 ottxor Exp $
+
+ 08 Dec 2012; Christoph Junghans <ottxor@gentoo.org> gromacs-4.5.5-r1.ebuild,
+ gromacs-4.6_beta2.ebuild:
+ CMAKE_BUILD_DIR -> BUILD_DIR
*gromacs-4.6_beta2 (07 Dec 2012)
diff --git a/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild b/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild
index 3cc034e83190..96690e3f1925 100644
--- a/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild,v 1.10 2012/10/19 09:50:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild,v 1.11 2012/12/08 22:15:02 ottxor Exp $
EAPI="4"
@@ -166,23 +166,23 @@ src_configure() {
[ "${x}" = "double" ] && p="-DGMX_DOUBLE=ON" || p="-DGMX_DOUBLE=OFF"
mycmakeargs=( ${mycmakeargs_pre[@]} ${p} -DGMX_MPI=OFF
-DGMX_BINARY_SUFFIX="${suffix}" -DGMX_LIBS_SUFFIX="${suffix}" )
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}" cmake-utils_src_configure
+ BUILD_DIR="${WORKDIR}/${P}_${x}" cmake-utils_src_configure
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
mycmakeargs=( ${mycmakeargs_pre[@]} ${p} -DGMX_MPI=ON
-DGMX_BINARY_SUFFIX="_mpi${suffix}" -DGMX_LIBS_SUFFIX="_mpi${suffix}" )
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" cmake-utils_src_configure
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" cmake-utils_src_configure
done
}
src_compile() {
for x in ${GMX_DIRS}; do
einfo "Compiling for ${x} precision"
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}"\
+ BUILD_DIR="${WORKDIR}/${P}_${x}"\
cmake-utils_src_compile
use mpi || continue
einfo "Compiling for ${x} precision with mpi"
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}_mpi"\
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi"\
cmake-utils_src_compile mdrun
done
}
@@ -199,12 +199,12 @@ src_test() {
src_install() {
for x in ${GMX_DIRS}; do
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}" \
+ BUILD_DIR="${WORKDIR}/${P}_${x}" \
cmake-utils_src_install
use mpi || continue
#cmake-utils_src_install does not support args
#using cmake-utils_src_compile instead
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" \
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" \
cmake-utils_src_make install-mdrun DESTDIR="${D}"
done
diff --git a/sci-chemistry/gromacs/gromacs-4.6_beta2.ebuild b/sci-chemistry/gromacs/gromacs-4.6_beta2.ebuild
index 80ffce73c2d4..478742a691ff 100644
--- a/sci-chemistry/gromacs/gromacs-4.6_beta2.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.6_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.6_beta2.ebuild,v 1.1 2012/12/07 02:52:37 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.6_beta2.ebuild,v 1.2 2012/12/08 22:15:02 ottxor Exp $
EAPI=5
@@ -144,13 +144,13 @@ src_configure() {
mycmakeargs=( ${mycmakeargs_pre[@]} ${p} -DGMX_MPI=OFF
$(cmake-utils_use threads GMX_THREAD_MPI) ${cuda}
-DGMX_BINARY_SUFFIX="${suffix}" -DGMX_LIBS_SUFFIX="${suffix}" )
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}" cmake-utils_src_configure
+ BUILD_DIR="${WORKDIR}/${P}_${x}" cmake-utils_src_configure
if [[ ${x} = float ]] && use openmm; then
einfo "Configuring for openmm build"
mycmakeargs=( ${mycmakeargs_pre[@]} ${p} -DGMX_MPI=OFF
-DGMX_THREAD_MPI=OFF -DGMX_GPU=OFF -DGMX_OPENMM=ON
-DGMX_BINARY_SUFFIX="openmm" -DGMX_LIBS_SUFFIX="openmm" )
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_openmm" \
+ BUILD_DIR="${WORKDIR}/${P}_openmm" \
OPENMM_ROOT_DIR="${EPREFIX}/usr" cmake-utils_src_configure
fi
use mpi || continue
@@ -158,23 +158,23 @@ src_configure() {
mycmakeargs=( ${mycmakeargs_pre[@]} ${p} -DGMX_THREAD_MPI=OFF
-DGMX_MPI=ON ${cuda}
-DGMX_BINARY_SUFFIX="_mpi${suffix}" -DGMX_LIBS_SUFFIX="_mpi${suffix}" )
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" CC="mpicc" cmake-utils_src_configure
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" CC="mpicc" cmake-utils_src_configure
done
}
src_compile() {
for x in ${GMX_DIRS}; do
einfo "Compiling for ${x} precision"
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}"\
+ BUILD_DIR="${WORKDIR}/${P}_${x}"\
cmake-utils_src_compile
if [[ ${x} = float ]] && use openmm; then
einfo "Compiling for openmm build"
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_openmm"\
+ BUILD_DIR="${WORKDIR}/${P}_openmm"\
cmake-utils_src_compile mdrun
fi
use mpi || continue
einfo "Compiling for ${x} precision with mpi"
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}_mpi"\
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi"\
cmake-utils_src_compile mdrun
done
}
@@ -191,14 +191,14 @@ src_test() {
src_install() {
for x in ${GMX_DIRS}; do
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}" \
+ BUILD_DIR="${WORKDIR}/${P}_${x}" \
cmake-utils_src_install
if [[ ${x} = float ]] && use openmm; then
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_openmm" \
+ BUILD_DIR="${WORKDIR}/${P}_openmm" \
DESTDIR="${D}" cmake-utils_src_make install-mdrun
fi
use mpi || continue
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" \
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" \
DESTDIR="${D}" cmake-utils_src_make install-mdrun
done