summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild')
-rw-r--r--sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild b/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild
index 3cc034e83190..96690e3f1925 100644
--- a/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild
+++ b/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild,v 1.10 2012/10/19 09:50:26 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-4.5.5-r1.ebuild,v 1.11 2012/12/08 22:15:02 ottxor Exp $
EAPI="4"
@@ -166,23 +166,23 @@ src_configure() {
[ "${x}" = "double" ] && p="-DGMX_DOUBLE=ON" || p="-DGMX_DOUBLE=OFF"
mycmakeargs=( ${mycmakeargs_pre[@]} ${p} -DGMX_MPI=OFF
-DGMX_BINARY_SUFFIX="${suffix}" -DGMX_LIBS_SUFFIX="${suffix}" )
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}" cmake-utils_src_configure
+ BUILD_DIR="${WORKDIR}/${P}_${x}" cmake-utils_src_configure
use mpi || continue
einfo "Configuring for ${x} precision with mpi"
mycmakeargs=( ${mycmakeargs_pre[@]} ${p} -DGMX_MPI=ON
-DGMX_BINARY_SUFFIX="_mpi${suffix}" -DGMX_LIBS_SUFFIX="_mpi${suffix}" )
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" cmake-utils_src_configure
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" cmake-utils_src_configure
done
}
src_compile() {
for x in ${GMX_DIRS}; do
einfo "Compiling for ${x} precision"
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}"\
+ BUILD_DIR="${WORKDIR}/${P}_${x}"\
cmake-utils_src_compile
use mpi || continue
einfo "Compiling for ${x} precision with mpi"
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}_mpi"\
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi"\
cmake-utils_src_compile mdrun
done
}
@@ -199,12 +199,12 @@ src_test() {
src_install() {
for x in ${GMX_DIRS}; do
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}" \
+ BUILD_DIR="${WORKDIR}/${P}_${x}" \
cmake-utils_src_install
use mpi || continue
#cmake-utils_src_install does not support args
#using cmake-utils_src_compile instead
- CMAKE_BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" \
+ BUILD_DIR="${WORKDIR}/${P}_${x}_mpi" \
cmake-utils_src_make install-mdrun DESTDIR="${D}"
done