summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2010-09-20 04:50:54 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2010-09-20 04:50:54 +0000
commita7d3c80ea6657ed00c3058d6ca6133d2058ff048 (patch)
treeff746d4bbf3da25cd727a31a335062572f51c14c /sci-biology/vaal/vaal-1.6.ebuild
parent20 Sep 2010; Zac Medico <zmedico@gentoo.org> portage-9999.ebuild: (diff)
downloadgentoo-2-a7d3c80ea6657ed00c3058d6ca6133d2058ff048.tar.gz
gentoo-2-a7d3c80ea6657ed00c3058d6ca6133d2058ff048.tar.bz2
gentoo-2-a7d3c80ea6657ed00c3058d6ca6133d2058ff048.zip
Version bump. Addresses boost problems and compilation issues
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/vaal/vaal-1.6.ebuild')
-rw-r--r--sci-biology/vaal/vaal-1.6.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-biology/vaal/vaal-1.6.ebuild b/sci-biology/vaal/vaal-1.6.ebuild
new file mode 100644
index 000000000000..9d6c01769235
--- /dev/null
+++ b/sci-biology/vaal/vaal-1.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/vaal/vaal-1.6.ebuild,v 1.1 2010/09/20 04:50:54 weaver Exp $
+
+EAPI="2"
+
+inherit base autotools
+
+DESCRIPTION="A variant ascertainment algorithm that can be used to detect SNPs, indels, and other polymorphisms"
+HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
+SRC_URI="ftp://ftp.broad.mit.edu/pub/crd/VAAL/VAAL.${PV}.tgz
+ ftp://ftp.broad.mit.edu/pub/crd/VAAL/VAAL_manual.doc"
+
+LICENSE="Whitehead-MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-libs/boost-1.41.0-r3"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-flags.patch
+)
+
+S="${WORKDIR}/vaal-33805"
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_install() {
+ einstall || die
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}/VAAL_manual.doc"
+}