summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-09-04 18:16:18 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-09-04 18:16:18 +0000
commitaed7aa8fedb08eb42add56b959b9bdbac3140f2e (patch)
tree2f2c9bc63ce42d6c13a8d14e3caabfdef477eed5 /sci-biology/kalign/kalign-2.03-r1.ebuild
parentRespect LDFLAGS, bug 335988. (diff)
downloadgentoo-2-aed7aa8fedb08eb42add56b959b9bdbac3140f2e.tar.gz
gentoo-2-aed7aa8fedb08eb42add56b959b9bdbac3140f2e.tar.bz2
gentoo-2-aed7aa8fedb08eb42add56b959b9bdbac3140f2e.zip
Respect CC,LDFLAGS wrt bug 335952. Thanks to Diego for the report and Ross Smith <gaurdro@gmail.com> for the patch.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/kalign/kalign-2.03-r1.ebuild')
-rw-r--r--sci-biology/kalign/kalign-2.03-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-biology/kalign/kalign-2.03-r1.ebuild b/sci-biology/kalign/kalign-2.03-r1.ebuild
new file mode 100644
index 000000000000..8cc1772b7851
--- /dev/null
+++ b/sci-biology/kalign/kalign-2.03-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/kalign/kalign-2.03-r1.ebuild,v 1.1 2010/09/04 18:16:18 xarthisius Exp $
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Global and progressive multiple sequence alignment"
+HOMEPAGE="http://msa.cgb.ki.se/"
+SRC_URI="mirror://debian/pool/main/k/kalign/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -e "s/\$(CFLAGS) \$(OBJECTS)/\$(LDFLAGS) &/" \
+ -i Makefile.in || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin kalign || die
+ dodoc README || die
+}