summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2015-03-08 20:18:06 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2015-03-08 20:18:06 +0000
commit5dc9f807a55a55586da023058e1118b59bb81956 (patch)
tree782933cb832a76ba693d75c8641c8222eba76dc8 /net-misc/pssh
parentFix gst post-patch, thanks to Sebastian Lackner and NP-Hardass. No revbump (a... (diff)
downloadgentoo-2-5dc9f807a55a55586da023058e1118b59bb81956.tar.gz
gentoo-2-5dc9f807a55a55586da023058e1118b59bb81956.tar.bz2
gentoo-2-5dc9f807a55a55586da023058e1118b59bb81956.zip
Port to distutils-r1. Thanks to Ian Delaney <idella4@gentoo.org> for the patch. Fixes bug #542438. Drop old
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'net-misc/pssh')
-rw-r--r--net-misc/pssh/ChangeLog9
-rw-r--r--net-misc/pssh/pssh-2.2.2.ebuild30
-rw-r--r--net-misc/pssh/pssh-2.3.1.ebuild22
3 files changed, 20 insertions, 41 deletions
diff --git a/net-misc/pssh/ChangeLog b/net-misc/pssh/ChangeLog
index 00cc53b8394e..339d43d4c4a4 100644
--- a/net-misc/pssh/ChangeLog
+++ b/net-misc/pssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/pssh
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pssh/ChangeLog,v 1.8 2014/08/10 20:46:29 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pssh/ChangeLog,v 1.9 2015/03/08 20:18:06 xarthisius Exp $
+
+ 08 Mar 2015; Kacper Kowalik <xarthisius@gentoo.org> -pssh-2.2.2.ebuild,
+ pssh-2.3.1.ebuild:
+ Port to distutils-r1. Thanks to Ian Delaney <idella4@gentoo.org> for the
+ patch. Fixes bug #542438. Drop old
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> pssh-2.1.1.ebuild,
pssh-2.2.2.ebuild:
diff --git a/net-misc/pssh/pssh-2.2.2.ebuild b/net-misc/pssh/pssh-2.2.2.ebuild
deleted file mode 100644
index a22f72e21ae1..000000000000
--- a/net-misc/pssh/pssh-2.2.2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pssh/pssh-2.2.2.ebuild,v 1.4 2014/08/10 20:46:29 slyfox Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.5"
-inherit distutils
-
-DESCRIPTION="This package provides parallel versions of the openssh tools"
-HOMEPAGE="http://code.google.com/p/parallel-ssh/"
-SRC_URI="http://parallel-ssh.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="net-misc/openssh
- !net-misc/putty"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-# Requires ssh access to run.
-RESTRICT="test"
-
-PYTHON_MODNAME=psshlib
-
-src_prepare() {
- sed -i -e "s|man/man1'|share/&|g" setup.py || die
-}
diff --git a/net-misc/pssh/pssh-2.3.1.ebuild b/net-misc/pssh/pssh-2.3.1.ebuild
index c9b552aabda7..5a3f66a5eece 100644
--- a/net-misc/pssh/pssh-2.3.1.ebuild
+++ b/net-misc/pssh/pssh-2.3.1.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pssh/pssh-2.3.1.ebuild,v 1.1 2012/08/18 10:33:33 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pssh/pssh-2.3.1.ebuild,v 1.2 2015/03/08 20:18:06 xarthisius Exp $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="*:2.5"
-inherit distutils
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
DESCRIPTION="PSSH provides parallel versions of OpenSSH and related tools"
HOMEPAGE="http://code.google.com/p/parallel-ssh/"
@@ -19,14 +21,16 @@ IUSE=""
RDEPEND="net-misc/openssh
!net-misc/putty"
DEPEND="${RDEPEND}
- dev-python/setuptools"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
# Requires ssh access to run.
RESTRICT="test"
-PYTHON_MODNAME=psshlib
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
-src_prepare() {
+python_prepare_all() {
sed -i -e "s|man/man1'|share/&|g" setup.py || die
- distutils_src_prepare
+ distutils-r1_python_prepare_all
}