summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pssh/pssh-2.3.1.ebuild')
-rw-r--r--net-misc/pssh/pssh-2.3.1.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/net-misc/pssh/pssh-2.3.1.ebuild b/net-misc/pssh/pssh-2.3.1.ebuild
index c9b552aabda7..5a3f66a5eece 100644
--- a/net-misc/pssh/pssh-2.3.1.ebuild
+++ b/net-misc/pssh/pssh-2.3.1.ebuild
@@ -1,11 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pssh/pssh-2.3.1.ebuild,v 1.1 2012/08/18 10:33:33 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pssh/pssh-2.3.1.ebuild,v 1.2 2015/03/08 20:18:06 xarthisius Exp $
-EAPI=4
+EAPI=5
-PYTHON_DEPEND="*:2.5"
-inherit distutils
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
DESCRIPTION="PSSH provides parallel versions of OpenSSH and related tools"
HOMEPAGE="http://code.google.com/p/parallel-ssh/"
@@ -19,14 +21,16 @@ IUSE=""
RDEPEND="net-misc/openssh
!net-misc/putty"
DEPEND="${RDEPEND}
- dev-python/setuptools"
+ dev-python/setuptools[${PYTHON_USEDEP}]"
# Requires ssh access to run.
RESTRICT="test"
-PYTHON_MODNAME=psshlib
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
-src_prepare() {
+python_prepare_all() {
sed -i -e "s|man/man1'|share/&|g" setup.py || die
- distutils_src_prepare
+ distutils-r1_python_prepare_all
}