summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-19 11:24:38 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-19 11:24:38 +0000
commit4efaccb6e2ce09ca586d9edd4ff144bfb97fe571 (patch)
tree421274755f483e9947442f1b167509f4317f8b01 /net-libs
parentAdd missing pair of quotation marks. (diff)
downloadgentoo-2-4efaccb6e2ce09ca586d9edd4ff144bfb97fe571.tar.gz
gentoo-2-4efaccb6e2ce09ca586d9edd4ff144bfb97fe571.tar.bz2
gentoo-2-4efaccb6e2ce09ca586d9edd4ff144bfb97fe571.zip
Python fixes, use eapi3.
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-farsight/ChangeLog5
-rw-r--r--net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild19
2 files changed, 19 insertions, 5 deletions
diff --git a/net-libs/telepathy-farsight/ChangeLog b/net-libs/telepathy-farsight/ChangeLog
index 94eb1fd357e1..6631cd8b2cea 100644
--- a/net-libs/telepathy-farsight/ChangeLog
+++ b/net-libs/telepathy-farsight/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/telepathy-farsight
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farsight/ChangeLog,v 1.15 2011/02/07 18:21:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farsight/ChangeLog,v 1.16 2011/02/19 11:24:38 pacho Exp $
+
+ 19 Feb 2011; Pacho Ramos <pacho@gentoo.org> telepathy-farsight-0.0.15.ebuild:
+ Python fixes, use eapi3.
07 Feb 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Add gnome to metadata as talked between us since empathy relies on this.
diff --git a/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild b/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild
index 5d8af6e67406..5cc5895a53c4 100644
--- a/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild
+++ b/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild,v 1.1 2010/09/29 10:46:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild,v 1.2 2011/02/19 11:24:38 pacho Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python
DESCRIPTION="Farsight connection manager for the Telepathy framework"
HOMEPAGE="http://telepathy.freedesktop.org"
@@ -13,7 +16,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE="python"
-RDEPEND=">=dev-libs/glib-2.16
+RDEPEND=">=dev-libs/glib-2.16:2
>=sys-apps/dbus-0.60
>=dev-libs/dbus-glib-0.60
>=net-libs/telepathy-glib-0.7.34
@@ -24,6 +27,14 @@ RDEPEND=">=dev-libs/glib-2.16
DEPEND="${RDEPEND}"
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
src_configure() {
econf $(use_enable python)
}