summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild')
-rw-r--r--net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild b/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild
index 5d8af6e67406..5cc5895a53c4 100644
--- a/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild
+++ b/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild,v 1.1 2010/09/29 10:46:31 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farsight/telepathy-farsight-0.0.15.ebuild,v 1.2 2011/02/19 11:24:38 pacho Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python
DESCRIPTION="Farsight connection manager for the Telepathy framework"
HOMEPAGE="http://telepathy.freedesktop.org"
@@ -13,7 +16,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE="python"
-RDEPEND=">=dev-libs/glib-2.16
+RDEPEND=">=dev-libs/glib-2.16:2
>=sys-apps/dbus-0.60
>=dev-libs/dbus-glib-0.60
>=net-libs/telepathy-glib-0.7.34
@@ -24,6 +27,14 @@ RDEPEND=">=dev-libs/glib-2.16
DEPEND="${RDEPEND}"
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
src_configure() {
econf $(use_enable python)
}