summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-16 06:21:52 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-16 06:21:52 +0000
commit503cd7cb89510a35650be66f9008ec0f32bdcb28 (patch)
tree3e22a113fb826bd68316a3cc6b8079874bc02e91 /media-gfx/feh/files
parentold (diff)
downloadgentoo-2-503cd7cb89510a35650be66f9008ec0f32bdcb28.tar.gz
gentoo-2-503cd7cb89510a35650be66f9008ec0f32bdcb28.tar.bz2
gentoo-2-503cd7cb89510a35650be66f9008ec0f32bdcb28.zip
Make xinerama support optional #139594 by Viktor Griph.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'media-gfx/feh/files')
-rw-r--r--media-gfx/feh/files/digest-feh-1.3.42
-rw-r--r--media-gfx/feh/files/feh-1.3.4-headers.patch18
-rw-r--r--media-gfx/feh/files/feh-1.3.4-xinerama.patch43
3 files changed, 63 insertions, 0 deletions
diff --git a/media-gfx/feh/files/digest-feh-1.3.4 b/media-gfx/feh/files/digest-feh-1.3.4
index 268af30ff3b8..964a45b78439 100644
--- a/media-gfx/feh/files/digest-feh-1.3.4
+++ b/media-gfx/feh/files/digest-feh-1.3.4
@@ -1 +1,3 @@
MD5 3d35ba3d2f0693b019800787f1103891 feh-1.3.4.tar.gz 409530
+RMD160 7e27d31cf974b30fc321d4dbef2fd46fbd21d34c feh-1.3.4.tar.gz 409530
+SHA256 81b9f2bbc15ffda4640958701753447b95cd2cbf11bc8e85dd00fdd2a2f83124 feh-1.3.4.tar.gz 409530
diff --git a/media-gfx/feh/files/feh-1.3.4-headers.patch b/media-gfx/feh/files/feh-1.3.4-headers.patch
new file mode 100644
index 000000000000..16070f770b04
--- /dev/null
+++ b/media-gfx/feh/files/feh-1.3.4-headers.patch
@@ -0,0 +1,18 @@
+--- src/md5.c
++++ src/md5.c
+@@ -39,6 +39,7 @@
+ */
+
+ #include "md5.h"
++#include <string.h>
+
+ #ifdef TEST
+ /*
+@@ -46,7 +47,6 @@
+ * The test program should print out the same values as given in section
+ * A.5 of RFC 1321, reproduced below.
+ */
+-#include <string.h>
+ main()
+ {
+ static const char *const test[7] = {
diff --git a/media-gfx/feh/files/feh-1.3.4-xinerama.patch b/media-gfx/feh/files/feh-1.3.4-xinerama.patch
new file mode 100644
index 000000000000..af435d02cf14
--- /dev/null
+++ b/media-gfx/feh/files/feh-1.3.4-xinerama.patch
@@ -0,0 +1,43 @@
+--- feh-1.3.4/configure.in
++++ feh-1.3.4/configure.in
+@@ -41,11 +41,25 @@
+ AC_SUBST(GIBLIB_CFLAGS)
+
+ dnl Check for Xinerama
+-LIBS="-L/usr/X11R6/lib $LIBS -lm -ljpeg"
+-AC_CHECK_LIB(Xext,XMissingExtension)
+-AC_CHECK_LIB(Xinerama,XineramaQueryScreens)
+-AC_SUBST(HAVE_XINERAMA)
+-AC_SUBST(XINERAMA_LIBS)
++AC_ARG_ENABLE(xinerama,
++ AC_HELP_STRING([--disable-xinerama],[disable Xinerama multi screen support]),
++ [
++ if test x"$enableval" = xyes; then
++ with_xinerama="yes"
++ else
++ with_xinerama="no"
++ fi
++ ],
++ [with_xinerama="detect"]
++)
++if test x"$with_xinerama" != xno; then
++ AC_CHECK_LIB(Xext,XMissingExtension,[
++ AC_CHECK_LIB(Xinerama,XineramaQueryScreens,[
++ AC_DEFINE(HAVE_LIBXINERAMA, [], [Enable Xinerama support])
++ LIBS="$LIBS -lXext -lXinerama"
++ ])
++ ])
++fi
+ AC_CHECK_LIB(jpeg, jpeg_destroy_decompress)
+
+ dnl AC_CHECK_FUNC(getopt_long,,[AC_LIBOBJ="$AC_LIBOBJ getopt.o getopt1.o"])
+--- feh-1.3.4/src/Makefile.am
++++ feh-1.3.4/src/Makefile.am
+@@ -1,7 +1,6 @@
+ # A list of all the files in the current directory which can be regenerated
+ MAINTAINERCLEANFILES = Makefile.in
+
+-LDFLAGS = -L/usr/X11R6/lib -L/usr/local/lib -lz -lpng
+ INCLUDES = -I/usr/X11R6/include $(X_CFLAGS) \
+ -I$(prefix)/include -I$(includedir) \
+ -I. -I$(top_srcdir)/src \